Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

stefi01

flsun kossel sd card contents and pre configured marlin 1.19

by stefi01 Oct 18, 2017
Download All Files

Thing Apps Enabled

Please Login to Comment

I have been watching beginner Arduino videos but do not remember this subject, I will spend some more time looking.
I am using a Mac does that make a difference?

arduino make versions for all operating systems so no, will all be the same

you could always try ..... download marlin 1.19 from http://marlinfw.org/meta/download/
then download the below two files and places them into the downloaded marlin folder, over writing the origianls.

also.... if you go to https://discordapp.com/ and sign up you can live chat with developers and many of the marlin community, its like a chat room but for marlin firmware, you can ask all the questions you like there, once you sign up with discord you will need an invite link so just message me and i will send it to you, the link will only be valid for 1 day so thats why i cant just post it here

Comments deleted.

Thank you for your prompt response.
I downloaded marlin following the instructions in this GitHub instruction ( https://github.com/FLSun3dp/FLSun-Kossel-Mini/wiki/01.-Software-and-Firmware ). I have not been able to use that as it is designed for the FLSUN Kossel mini.
I have the Marling software in its own directory and made changes to Configuration.h as directed but using full size Kossel measurements, I have been unsuccessful making that work so when I found your item in Thingiverse I downloaded your files and ran into the problem on not being able to open your .ini with Arduino. I assume my lack of knowledge was the problem. How do I open your .ini file in Arduino when my version is looking for a .ino file, or have I missed something completely?
Norm

ignore the ini file, download the file named marlin 1 19 and as long as arduino is installed on your pc then you should see a file named marlin 4 kossel ino and this should have the arduino logo next to it, if you are as new to arduino as i think you are then watch some youtube videos on arduino for beginers as there are a few other settings too

I am confused with the instructions and .ino file provided.
I have no .ino file but I start Marlin in Arduino by using a .ini file.
Obviously something I do not understand (I am new at this).
Can you help?
Thank you.

did you download arduino software and unzip the marlin firmware file? you should not have to change much in the files but the link kinda explains it.
https://www.youtube.com/watch?v=3gwWVFtdg-4&t=915s

hey anyone know how to upload firmware to a flsun delta?

I keep getting this error when I try to compile it...

Arduino: 1.6.1 (Windows 8.1), Board: "Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)"

In file included from MarlinConfig.h:39:0,
from Marlin.h:36,
from blinkm.cpp:28:
SanityCheck.h:33:4: error: #error "Marlin requires C++11 support (gcc >= 4.7, Arduino IDE >= 1.6.8). Please upgrade your toolchain."

error "Marlin requires C++11 support (gcc >= 4.7, Arduino IDE >= 1.6.8). Please upgrade your toolchain."

^
In file included from MarlinConfig.h:39:0,
from Marlin.h:36,
from blinkm.cpp:28:
SanityCheck.h:254:14: error: expected constructor, destructor, or type conversion before '(' token
static_assert(X_MAX_LENGTH >= X_BED_SIZE && Y_MAX_LENGTH >= Y_BED_SIZE,
^
SanityCheck.h:500:14: error: expected constructor, destructor, or type conversion before '(' token
static_assert(1 >= 0
^
SanityCheck.h:559:14: error: expected constructor, destructor, or type conversion before '(' token
static_assert(1 >= 0
^
SanityCheck.h:667:14: error: expected constructor, destructor, or type conversion before '(' token
static_assert(1 >= 0
^
SanityCheck.h:1140:14: error: expected constructor, destructor, or type conversion before '(' token
static_assert(1 >= 0
^
SanityCheck.h:1317:1: error: 'constexpr' does not name a type
constexpr float sanity_arr_1[] = DEFAULT_AXIS_STEPS_PER_UNIT,
^
SanityCheck.h:1317:1: note: C++11 'constexpr' only available with -std=c++11 or -std=gnu++11
SanityCheck.h:1317:61: error: expected unqualified-id before ',' token
constexpr float sanity_arr_1[] = DEFAULT_AXIS_STEPS_PER_UNIT,
^
SanityCheck.h:1318:32: error: expected constructor, destructor, or type conversion before '=' token
sanity_arr_2[] = DEFAULT_MAX_FEEDRATE,
^
SanityCheck.h:1318:54: error: expected unqualified-id before ',' token
sanity_arr_2[] = DEFAULT_MAX_FEEDRATE,
^
SanityCheck.h:1319:32: error: expected constructor, destructor, or type conversion before '=' token
sanity_arr_3[] = DEFAULT_MAX_ACCELERATION;
^
SanityCheck.h:1320:14: error: expected constructor, destructor, or type conversion before '(' token
static_assert(COUNT(sanity_arr_1) >= XYZE, "DEFAULT_AXIS_STEPS_PER_UNIT requires 4 (or more) elements.");
^
SanityCheck.h:1321:14: error: expected constructor, destructor, or type conversion before '(' token
static_assert(COUNT(sanity_arr_2) >= XYZE, "DEFAULT_MAX_FEEDRATE requires 4 (or more) elements.");
^
SanityCheck.h:1322:14: error: expected constructor, destructor, or type conversion before '(' token
static_assert(COUNT(sanity_arr_3) >= XYZE, "DEFAULT_MAX_ACCELERATION requires 4 (or more) elements.");
^
SanityCheck.h:1323:14: error: expected constructor, destructor, or type conversion before '(' token
static_assert(COUNT(sanity_arr_1) <= XYZE_N, "DEFAULT_AXIS_STEPS_PER_UNIT has too many elements.");
^
SanityCheck.h:1324:14: error: expected constructor, destructor, or type conversion before '(' token
static_assert(COUNT(sanity_arr_2) <= XYZE_N, "DEFAULT_MAX_FEEDRATE has too many elements.");
^
SanityCheck.h:1325:14: error: expected constructor, destructor, or type conversion before '(' token
static_assert(COUNT(sanity_arr_3) <= XYZE_N, "DEFAULT_MAX_ACCELERATION has too many elements.");
^
Error compiling.

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.

I noticed that you set the rod length to 268 in configuration.h instead of the usual 267. Is there a reason for that?

that is how my printer messured it when i did a auto calibration

Comments deleted.

new one but if you have the old then go to the lcd menu and go to delta config and marlin will configure itself for the old

Is this marlin configured for the new style flsun effector or the old?