Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Z leadscrew problem?

Please Login to Comment

Hello, i have been having this issue for a while now, i cannot seem to level the bed because the x rails are not level, so i printed out the z leveling tool and leveled the z axis/ x rails. it seems like it stays level until i move in the z axis and then it becomes unlevel again, its always the right side being lower than the left, as if the right stepper is moving slower than the left or something.

my troubleshooting steps
-tried tightening couplers
-tried leveling the z axis with the printed tool, printed on my anet so i know its level.

if it helps, the only mods that i have on this printer is a glass bed and the i3 plus+ firmware on the main board and the LCD, i was having the issue before upgrading the firmware so i don't think that's the issue.

I had similar issues on that right side. Ended up being some loose screws that were terribly hard to get to. They were at the brass z-axis nut (which may be what you mean by tightening couplers). Not sure if that is the issue for you, but that was it for me.