Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Customizer App is not working at moment?

Please Login to Comment

When opening things (customizable) and try to customize them
(https://www.thingiverse.com/apps/customizer/run?thing_id=nnnnn)

customizer opens but with no content/function (empty hull)

Tried with different things and web browser.
Any idea?

In case you want to try the offline version, here is a video walk through of using the Customizer in the nightly build of the OpenSCAD IDE with customizable things from Thingiverse.

https://www.youtube.com/watch?v=knKgMEod11U

Still doesn't work for me, I get...

<RuntimeError: Failed to get https://www.thingiverse.com/download:xxxxx 403: Forbidden>

This is still not working for me but what you are able to do to continue to use the designs and customize things is to open customizer for the item you want to customize, select view source from the top right, copy and paste the source into a new openSCAD file, and edit then build the STL from there. It's not too bad even if you've never coded before as usually just the top portion explains which variables to edit.

I totally agree with using the actual OpenSCAD app.

The 'Development Snapshots' of OpenSCAD have a Customizer built-in. The links are halfway down the page at this URL:

http://www.openscad.org/downloads.html

Not working ? was this ever fixed?

<RuntimeError: Failed to get https://www.thingiverse.com/download:3145672 403: Forbidden>

It seems to work for some people, in some browsers, and fail for others.
Not sure what the problem might be.

ANY UPDATE,,,,, STILL DOES NOT WORK...

Comments deleted.

Is it still down or am I doing something wrong?

I'm trying now for several hours - NOTHING but ERROR forbiddddddddddeeeeeeeeeeeeennn!!!!!
Why isn't this fixed????
It is frustrating!

If you are really in a pinch (or just want to use the Customizer) then try the 'Development Snapshots' of the actual OpenSCAD app. It has a better Customizer built into the app.

http://www.openscad.org/downloads.html

The installer links are about half way down the page.

Thanks for the tip. I will look into that.

Nope its broken and no one cares any more. Has been busted since 16th of December.

Too bad. Just when I had the time to start experimenting :(

Update!

So it should be back up and running. Please let us know if you find any issues. We have tested in house and seems like it should be working as excepted. Sorry for the delay. Merry Christmas and happy holidays everyone.

DevOps Guy @ Thingiverse

Update??????????
Update????????????????????????????????????????

Same on my side.
Tested it with "lithopane"
Customizer is working.

Then, when going into the personal queue following error occurs:

<RuntimeError: Failed to get https://www.thingiverse.com/download:385465 403: Forbidden>

So it seems a problem with access rights or thrusting still exists.


Edit:
A second try - 2 mins later did function well


So first of all, Thank you very much for getting customizer functional again.
Merry Christmas and happy holidays to the family and team!

Same here: Error on first try, but it works on second attempt of same creation

Mine refuses to work no matter how many times a try here is the error message

<RuntimeError: Failed to get https://www.thingiverse.com/download:2488071 403: Forbidden>

its working now for me, just one thing, after i click on "create thing" and then go to queue i got this ERROR:

<RuntimeError: Failed to get https://www.thingiverse.com/download:297001 403: Forbidden>

but if i return to customizer and click again on "create thing" it make it up to the 2nd to 4th try.

hrm Looking thanks.

Update on Customizer! While we welcome all the offers the community has given. We are close to have it back up. Please bare with me while I'm working on this. We have had to recreate the hosts from the ground up and try to figure out all the missing pieces. It is my sole mission today is to get customizer up and working again. Please stay tune for updates from me. This is the only application in our infrastructure that isn't a container and openscad take around 2 hours to compile from source with all of our customizations.

DevOps Guy @ Thingiverse

moos3, where can we see these customizations that Thingiverse has made to the OpenSCAD source code?

I'm not honestly sure. We will have to check with out legal team and see if we can open source or release these publicly.

Oh. I ask out of curiosity, and am not trying to open a can of worms, but does Thingiverse have a licensing arrangement with the OpenSCAD folks?

The way I understand the OpenSCAD license (at least the one stated here: https://github.com/openscad/openscad) any derivative works require distribution of the source code with changes.

Please remind the legal team that OpenSCAD is released under the GPL 2.0.

Please remind onebeartoe that the GPL does not dictate how you're allowed to use GPL software, it deals with source code. Thingiverse is entirely within their rights to host their own, customized version. They could even sell that service. What they can't do is sell the source code.

Update!!!!
We are very close! We are just fixing a oAuth Token issue. We should be back shortly!

DevOps Guy @ Thingiverse

So will customizer be broken forever now??????

Still not fixed.

Yup it's been down for a few days now which has been quite frustrating. Client error is: 503 (Service Unavailable: Back-end server is at capacity). Hopefully the fix by tomorrow morning will resolve it.

We are aware of customizer being down. We are working to restore this service and should have a resolution for this service by Tuesday morning. We are sorry for the inconvenience this has caused.

Good Wednesday morning! Like macropin mentioned below, is there any way the community can help? Maybe the Customizer source code should be released so that others can host it while thingiverse is down.

Do you guys need a hand getting this sorted? I'm happy to provide some consulting on DevOps best practices.

Any update on this? Any chance we could get a page in the future with the status of these site-applications? Thanks!

We are still working on this. We are sorry for the inconvenience this is causing. I'm trying to resolve this matter as quick as possible and we have our developers working on it.

Good Luck
and thx for keeping us informed

Thanks for working on this, I was getting really frustrated thinking it was a mystery update on my PC that broke it for me.

lol!

Same I thought.
Win X update.
Multiple boot.
Took hours till PC worked again.

Thank you for this information - good luck on solving problems!

same here, i deleted cache, i tried on diferent PCs but it seems that the problem is on the app server, maybe offline or in maintenance

I can confirm - customizer is offline right now. I've tried several different items/files and all just get a blank gray screen.