Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Problem with Cura; printing starts too high.

Please Login to Comment

Hi!

Recently I bought a Tevo Little Monster after the succes I had with the Tevo Tarantula,
However I do have a problem with Cura,

Whenever I prepare a print in Cura 3.1 the print always starts about 5 mm from the buildplate, which is wierd, ( I've tried several printer profiles as well as several firmware flavors, but to no succes)
I had the same problem in Slic3r but in Slic3r I was able to alter the Z-offset in the printer profile itself and it works,
The problem being with that is that Slic3r itself is quite limited...

Cura 3.1 has no such setting to my knowledge, and I already tried to change the starting G-CODE, but to no avail with really counter intuitive results...

For example this is the normal start G-CODE of a Deltabot profile;
G28 ;Home
G1 Z15.0 F6000 ;Move the platform down 15mm
;Prime the extruder
G92 E0
G1 F200 E3
G92 E0

I then altered that to;
G28 ;Home
G1 Z15.0 F6000 ;Move the platform down 15mm
;Prime the extruder
G92 E0
G1 F200 E3
G92 Z-5.1 E0 (-5.1 referring to the approximate distance it starts too high.)

What happened was that the printer even started printing higher than it already did, but not by 5.1mm but by something like 20mm even, I then tried to swap it to a positive number, but actually the same happened.
I really can;t make heads or tails of it,

LAter I tried the following;
I changed it to a G1 command, which does work. But then it just moves to its actual 0 position (now Z-5.1) and then when it starts to move to its first coördinate it moves back up 5.1mm again...

I've also examined the G-CODE files themselves but I can't figure it out,
Does anybody have the solution to this problem?

G28 X0 Y0 ;move X/Y to min endstops
G28 Z0
G1 Z15.0 F5000 ;Move the platform down 15mm
;Prime the extruder
G28 Z0
G92 E0

Sounds like you need to do Z height calibration, there are some good instructions on the Tevo Forum for this

G28 X0 Y0 ;move X/Y to min endstops
G28 Z0
G1 Z15.0 F5000 ;Move the platform down 15mm
;Prime the extruder
G28 Z0
G92 E0

I already did that, That's what the auto calibrate routine is for on the Tevo Little Monster,
I really don;t want to mess with the firmware, purely because I don;t actually own an adapter for that specific type of MicroSD

Still, it should be fixable in the slicer nevertheless. I know it's possible so that's what I'm doing.

Thanks anyway

Auto-calibration is only for bed compensation, you really need to set the Z offset in the printer setting not your slicer. You will also find the BLTouch is really crap and will not give repetitive or accurate results.

My settings cura3.0.4 works fine :)
G30 Z1.6 ---> is the Noizzle Hight ,

the higher the values, the closer the nozzle distance to the ground.
start for the time being 1.2 then 1.4 .... to the ground

Start Gcode

G28 ;Home
G92 E0
M280 PS3
G28 ; home all axes
G1 Z50 F25000 ; lift noizzle
G30 Z1.6 ; my noizzle hight - je mehr umso näher zum boden
M280 S7 ; Lift BL Sensor

end gcode

G92 E0
G1 E-8.0 F9000
M104 S0
M140 S0
G28 ; home x
;M84 ; disable motors

This helped me as well, thank you very much. Mine prints around Z1.0, it is very nice to be able to dial in the perfect layer in the start code like this.

Thank you! I'll try this,

I didn;t figure it would be a G30, I thought I needed to do this with the G92,
I'll Try it nevertheless!

Ritchie

EDIT: This worked! Thanks a lot! it's printing well now!