MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

BLTouch v3.1 not deploying after self test

by Ddocherty


I am having problems with my new BLTouch, its a v3.1 as opposed to the v2.2 I used previously. When I start the printer (with the hotend lifted) the BLTouch does its self test as expected and glows red (no blue in sight), however, once I try to start printing the pin does not drop and the nozzle crashes into the bed.

can anyone shed some light on the solution to this problem?


View Comment


by Ranger47

I've upgraded to UBUNTU 64 bit from 32 bit because I wanted a more recent version of Cura (3.1).

When I checked the software repository it had the same version of Cura but I noticed the PrusaSlicer was available so I installed it.
It definitely has more options than Cura did.
Though the TLM wasn't in its printer library, I set up a custom printer with the same start and end GCODE I used in Cura.

I was amazed at the improvement in my prints.

Is anyone else using PrusaSlicer?

What has your experience been?

View Comment


by cdalyai

Where can I find and down load the original files that came with the Tevo Little Monster. My printer is (1) One year old. I have all the updates but not the original. I'm trying to get a new BL Touch working but it does not want to respond with my updated soft ware.

View Comment

Problem with Cura; printing starts too high.

by RitchievanDaal


Recently I bought a Tevo Little Monster after the succes I had with the Tevo Tarantula,
However I do have a problem with Cura,

Whenever I prepare a print in Cura 3.1 the print always starts about 5 mm from the buildplate, which is wierd, ( I've tried several printer profiles as well as several firmware flavors, but to no succes)
I had the same problem in Slic3r but in Slic3r I was able to alter the Z-offset in the printer profile itself and it works,
The problem being with that is that Slic3r itself is quite limited...

Cura 3.1 has no such setting to my knowledge, and I already tried to change the starting G-CODE, but to no avail with really counter intuitive results...

For example this is the normal start G-CODE of a Deltabot profile;
G28 ;Home
G1 Z15.0 F6000 ;Move the platform down 15mm
;Prime the extruder
G92 E0
G1 F200 E3
G92 E0

I then altered that to;
G28 ;Home
G1 Z15.0 F6000 ;Move the platform down 15mm
;Prime the extruder
G92 E0
G1 F200 E3
G92 Z-5.1 E0 (-5.1 referring to the approximate distance it starts too high.)

What happened was that the printer even started printing higher than it already did, but not by 5.1mm but by something like 20mm even, I then tried to swap it to a positive number, but actually the same happened.
I really can;t make heads or tails of it,

LAter I tried the following;
I changed it to a G1 command, which does work. But then it just moves to its actual 0 position (now Z-5.1) and then when it starts to move to its first coördinate it moves back up 5.1mm again...

I've also examined the G-CODE files themselves but I can't figure it out,
Does anybody have the solution to this problem?

View Comment

Auto-calibration faulty after 2 years

by RitchievanDaal

Hi Guys,

So Back in 2018 I purchased my Tevo Little Monster,
Contrary to many hate posts about the machine I;ve actually been very happy with it,

The only thing I altered on it was the occasional thermistor,

Now 2 days ago the printer started to make a very harsh an agressive sound, as if the carriage was bumping into something,
at first I though this was because I was running smaal/thin prints at 140mm/s
But the sound persisted even when turning the speed all the way down to 50mm/s.

It turned out the X and Y carriages had a bit of play along the C-beam, I adjusted this and did an autocalibration run,
However the bed leveling now is way off, I don;t have any pictures right now, but lets say it prints a circle, starting at the Z-tower CCW, it takes a dip close to the X tower, then rises again between the X and Y towers whilst it prints quite allright on the rest of the bed,

This really puzzles me, I tried recalibrating multiple time,

  • Cleaned the bed meticulously,
  • The end stop probes/set screws are all set within 0.03mm deviation from one another (changing the lengths of these screws doesn;t change anything too by the way).
  • All the bolts on the entire machine are secured.

Could the BLTouch suddenly have broken?
Am I missing something hard-ware wuse, since this occured after altering the hardware...
I never had these problems with it before...

Any thoughts/advise?

I don't have any pictures or G-codes available right now, but if needed please let me know and I'll supply this ASAP

View Comment

Tevo problem

by zanatory

So i change any single part that i have at home of my tevo and he still not running the stop printig in middle of a print and show -50^C so i change th1 like always after the change th1 and th2 show 172°C so i was thinking mabye my mainboard get burned so i chang it aswell but with no Result. After hours changing parts and have no Result i noticed that when i put out the mainoard SD card it show th1 and th2 0°c so i change the card but it looks like i´m to stupid to get the firmware on it i used the update instructions but nothing happend the tevo go on but nothing will move , I hope someone will help me and tell me what i´m doing worng!

View Comment

Tevo Little Monster - Commands from Touchscreen not working....

by irocc

Please help - the touchscreen is working (everything that needs to be on the screen is there.... it goes into the menu options) but nothing is happening if for instants "Home" is pressed - Everything is working fine when I run a command from a pc thru the usb port.


View Comment

Tevo Little Monster Hotend replacement

by Jyoungun76

I recently bought an E3d Volcano from filastruder to replace the stock hotend on my LM. I do not know what all I need to change to make the hotend work or even if I bought the right one. I bought the standard E3D Volcano but I purchased 12V I don't know if this is right or not... It also came with a cartridge thermistor and I have no idea what to change to make this work with the stock firmware. Any help would be appreciated. I'm getting tired of having to rebuild this printer after every 2 or 3 successful prints. The bowden tube pulls loose and fouls the tube, then I have to take it apart and rebuild the hotend, but now the height has changed so I have to re-calibrate the whole printer.... just getting tired of it all.

View Comment

Faltering (next steps?)

by 1STerminus

So, I have made one attempt to get the printer working (printing) after achieving successful calibration and other operations (motion control, extruding filament, etc.) I made an attempt to install slicer software and do further configuration on the printer in order to prepare for printing.
I am not sure exactly what need to do from Step 1 to Step N in order to get it printing. The manual is pretty bad and I can't seem to find the information online about which tasks need to be performed to get it printing properly.

I apologize for my lack of experience I am sure this is somehow intuitive for folks who have been working with the technology any length of time. I was thinking I had chosen the wrong printer to begin with and should have built something smaller and more simple then worked up but I wanted the largest print capacity I could afford.

I suppose this is comical to contemplate and I will laugh at myself some day I am sure!

So, I use Linux mainly but have a windows 7 laptop I was using for the printer since it is still on the workbench. What configuration settings need to be changed in the LM before it can actually print. I assume something to do with where the first layer is in relation to the hot end? I guess there are some speed settings too. Do we edit the Monster.ini on the main control board (the filesystem on the microsd card?) I with I didn't have to ask all these questions, I wish the information I need to actually get it printing was in the manual. From looking at everything I've found including youtube I must be a dolt because people just seem to be printing with them without problems.

Thank you in advance for any knowledge about this procedure from end to end that you can share with me. I am sure my printer is working and put together well but I am challenged getting it printing. This is mainly due to being unsure what to do next, I guess.

  1. Task: Obtain slicing software. I chose Slic3r.
  2. Task: Configure printer. I think I have to edit Monster.ini on the main controller but am not sure.
  3. Task: Successful test print (my goal.)
View Comment