Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Nozzle and bed temperature

Please Login to Comment

I have an issue with temperatures, my printer does not "obey" the temperatures set in the slic3r for neither the nozzle nor the bed. No matter how I change the settings, it always goes to 230°C and 65°C. I think it has something to do with the Marlin firmware, however, I don't know how to change it. I used the "M303 E0 S230 C8" and "M303 E-1 S90 C8" commands on g-code, to calibrate the PID, maybe it has something to do with it.

Also, sorry for any grammar mistakes, english is not my first language :/

I think that has nothing to do with Marlin, it is probably the slicer that is doing that in the gcode. check if you have some gcode prefix that set that temperatures...
An easy way to check that out is to open the gcode file with a text editor and look for any M104 M109 M140 M190
Then you will have the confirmation that the temperature are set by the slicer.
I had some problems using Repetier and Slicer together so I slice the stl independently and then load the gcode file in pronterface.
Sometimes get quite confusing loading an stl into repetier and have it sliced automatically by slic3r so I would do the two operations separately...

You were right! The default code had some m190 and m109 "hidden" down below, I missed it. Thank you!

Did you save the values to EEPROM?

I can see these values on the "preheat" setting in the EEPROM configurations (Repetier-Host) but I don't use any preheat command while printing

After u run the M303 E-0 S230 C8 for extruder u need to save the setting as Phisterbut_Inc say in the EEPROM or u must add those setting to the start code. for me the EEProm is the better way cause those settings never change till change the hardware

Add an
M301 P21.08 I1.09 D101.56 (hope its clear that u use ur PID settings ;-)) )
and then a
M500
to save them

Same with heatbed

That doesn't answer the question. Did you save those values to EEPROM after you ran the PID tune command? You might also want to check that you're using PID control instead of dead time.