Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

3D printer heating issues-- showing at temp, 30 degrees less

Please Login to Comment

I'm having issues with my e3D v6 old style heater block with this thermistor: https://gulfcoast-robotics.com/products/2017-version-hex-screw-in-m3-ntc3950-100k-thermistor-3d-printer-extruder-hotend

when it claims to be at 200 Celsius, it is read to be at ~160-170 on a multimeter thermistor. In firmware, I ran PID autotune, changed temp sensor to Marlin 11, and have raised the max temp to 300 like the thermistor can reach. How can I solve this?

first thing to check is all the wiring connections from your control board to the thermistor . It being a resistive device its important the connections are good.
You may just have a bad thermistor which is best replaced or you could make your own temp table for it in firmware.
https://www.youtube.com/watch?v=qwboQDMY-h8&t=

It may also be your control board . As Arduino 8 bit boards cant read resistance the thermistor is part of a voltage divider circuit. If the fixed resistor on board is faulty or out of spec you will get incorrect voltages and therefore temp readings . Easiest way to check this is compare the hotend readings for the thermistor then swap it to the heated bed input of the control board. It should give the same temp reading
Good luck

I'm starting to think it might be a thermistor issue. I ran the calibration and got the thermistor within +- 5 centigrade. The weirdest thing is that now it seems to be shorting repeatably at 253 degrees Celsius. Any suggestions? I've emailed the manufacturer, though I'd love your opinion.

The calibration isn't for the thermistor Its for the PID control loop settings for the hotend heater. !! Yes inevitably it relates to the thermistor as the calibration adjusts the PID to give the best performance against the measured temperature.
What firmware are you using ?

Try to remove the thermistor and lay it on your heated bed Then heat up the bed as see if the temp reading follow the bed temp reading. There will be some difference between the 2 due to how and where they are mounted but it should follow temp changes !

If you are getting constant shorting issues just replace the thermistor and hope it isnt your control board

To the best of my knowledge, E3D have never had a hotend that uses a hex screw in type thermistor.
Whats weird in the link you provided is that the pictures don't show a hex type screw in !!! Only the last pic shows a hex screw in type.

I'm on the most recent stable release of marlin. That's a great idea with the bed test! I'll try that! I'm guess it may be a thermistor issue, I switched quickly T0 and T2 in marlin and the issue still occurs, strange that it shorts reliably at 253 degrees though. Or at least I get a reading of -26 that fluctuates in and out with the actual temperature, which implies to me a short.

It is for the old style e3D v6 blocks. Instead of a glass bead thermistor held in with a set screw, which always concerned me that I may accidentally break the glass bead, this thermistor screws in to the set screw hole. Feels safer to me (though it probably isn't)

E3D V4 & V5 both used glass bead . V6 early types used glassbead as well
As of V6 lite and V6 new heatblock with silicone sock they used cartridges
None used the screw in type!

Not sure its related but double check your max and min temp range in Marlin!

Right this is an aftermarket thing I got because I disliked the glass bead on my early type v6.

Min temp 170, max temp 315

right . The current E3D cartridges are certainly better than the bead types. Screw in should work too.

Try the bed test mentioned earlier . That way you should know if it the thermistor or the control board