Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Odd temp errors

Please Login to Comment

So I’m running a good old ramps 1.4 setup and it has worked great until now. It has randomly started stopping mid-print and showing a temp error on either the bed or the hot end. The odd part is that the hotter i have the bed the more likely it is to show the fault 50c and i can usually print for 30-60 mins, 65c and it won’t get past the first layer. If i do not use the heated bed no problem shows at all. Also, if i do not start a print and just leave the printer heating up i never get an error, it’s only once it starts the print.

Error messages that show up:
Error:MINTEMP triggered, system stopped! Heater_ID: bed
Error:MAXTEMP triggered, system stopped! Heater_ID: bed
Error:MINTEMP triggered, system stopped! Heater_ID: 0
Error:MAXTEMP triggered, system stopped! Heater_ID: 0

Again, it seems totally random which error will appear and none of them appear if i do not use the heated bed. All temperatures appear accurate and stable when it stops. I tried swapping the thermistor in the hot end and the errors stayed. I checked all the connectors are secure, wiggled every wire and still nothing.

I thought that maybe the data lines are getting a interference next to eachother so i separated the thermistor bed wires away from the hot end wires but it made no difference.

Anyone seen anything like this before? Any help is greatly appreciated.

Edit: SOLVED!
For some reason Marlin 1.1.0 wasn't showing the temp drops that would cause the fault. Updated to 1.1.5 and set PID settings for hot end and bed and now works fine. Worth noting that my heated bed is 5mm Aluminum so the PID settings are necessary.

Sounds like the bed thermistor wires are crossing, or shorting on each other, or at the bed, if they come into contact with metal, or a PCB through hole, which has a metal ridge, they can short to each other.
If shorted, they would trigger a MAX temp, as a short would be 0 resistance.
If a wire comes unplugged, or is disconnecting, it would be open, or full resistance.

with this version of Marlin I also notice a change in the quality of my prints for the worst, seems the tolerance is off and walls are more wavy then they used to be, but there was also an update to S3D also which might have something do with it . have you guys seem this issue also ?

I've not had any of that, I actually noticed an improvement because i also tuned my acceleration settings when i upgraded. Fixed lot's of other problems i was having too. I'm on 1.1.0 now, I'll try changing to the newly released 1.1.5 tonight and see if it helps but doubt I'll see a difference

Just finished trying this, hasn't made a difference

Edit: Actually i may have to eat my own words. I tried printing with PET at 240c hot end and 55c bed and it failed at the 10th layer rather than the first, this time the hot end temp showed 230c so it was actually a thermal cutoff. I tried printing with no fan and it kept dropping to around 230c but would recover before it timed out and cut off so I'll update the PID setting tonight and post back here is it's fixed. Thanks for the suggestion :)

Looks like 1.1.0 wasn't displaying the thermal drop for some reason?

Well, now 3 hours into a print fans running, so far no issues, I did run PID 3 times in a row before saving to the eeprom and then manually tweaked the " I " settings and all is working fine so far, the Ver 1.1.X bugfix also brought my prints the normal good quality. Hope you get yours solved also.

Yup, 4 hour print with no problems, just had to update PID and Marlin in the end. thanks! :)

Printed for 2 hours before my heater dropped too much and it failed, I'll up the watch temp period and try again over the weekend. What are the 'I' settings?

I've been printing with the newly flashed and haven't had a problem since. the "I" is the Integral, in Proportional, Integral, Derivative AKA PID
What I did was run the pid autotune a few times then heated up the hotend to 230 with fan on at 80%, used the menu, Control/ temp/ menu changed the "I" I raised up and or lowered by increments of 0.10 while looking at the temp read out till I landed on the setting that kept the temp stable. Don't forget to save those settings to your EEPROM before you turn off the printer.

i also Flashed with Marlin 1.1.x bugfix but have not tried it yet as I was fighting all evening with a pin bug for my fan extender , I finally got the parts cooling fans to work now, but have not tested to see if I got the same thermal run away errors, however, I can say that my thermal couplers do seem to be more stable then they were with marlin 1.1.X. nonetheless, if I get even just one Temp error again, im going back to the V1. and be done with it lol

Greetings, its a thermal protection error. I face the same problem until change the check values into conguration file on Marlin. These settings are in Configuration_adv.h file.

Thanks but that's not it, i get that error when i have fans set to 100%. It's something like 'Error:Heating, Thermal error'.

All my temps are correct when it crashes. The error i get is what shows when the thermistor has either shorted or disconnected.

I did try editing the thermal protection anyway but it made no difference, think it was set to 120 and 2, originally on 80 and 2.

what do you have your up to ? the Watch temp period is set to 100 with temp increase at 2 and I still get a temp error if the fan kicks on to close to the heatbed.

I've been fighting with this same problem ever since I switch to the new Marlin, I'm just about ready to switch back to the good ol'working ver 1 at this point I changed the tempwatch dog and im still having issues with it if the part cooling fan turns on anything less the 1 mm from the bed! keep in mind one of my printers has two thermal couplers and it not any better, my guess is, the new Marlin is better suited for more modern boards such a smoothie and duet perhaps

Ah, that could be it. I upgraded my Marlin a couple of month ago, but I mainly print in PLA without heated bed anyway so i may have just not noticed the problem. Glad I'm not just loosing my mind, I'll try going to an older version of Marlin tonight and report back

Would you mind reporting back? I know it's years later lol, but I'm having the same issue

Ha sorry! I did update my original post if you have a look. Yeah changing the firmware helped, an update came out shortly after this that helped a lot. The main issue was the temp safety cutout kept tripping because the part cooling fan was cooling down my aluminum bed, not so much it couldn't heat up but it made the pid setting all off so the safety cutout would step in. I don't remember the exact method now but a quick Google on setting PID should find many results

Good luck!

Ah yes; my bad! Thanks dude. Very interesting about PIDs, I really ought to recalibrate myself.

Starting to think my own issue is actually an ever-so-slightly loose wire connection to the extruder. I'm like "it can't possibly be that!" but, as is often the case, these things are more than possible