Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

RPI3 b+ with 3.5" screen

Please Login to Comment

Hi,
i recently purchased a 3.5" screen for my RPI 3.
I followed instruction to install the drivers, which seemed to worked as can see all the booting up texts.
I then followed the instructions to boot to browser with TUI
https://github.com/BillyBlaze/OctoPrint-TouchUI/wiki/Setup:-Boot-to-Browser

After the reboot and load, the screen stopped on a blank/black screen. moving the stylus on the screen, I can see the Octoprint log in screen behind the block around the mouse cursor.

the same when I stop the TUI and the Pi loads to the desktop. When I move the mouse with the stylus, I can see the wallpaper appear around the mouse cursor.

I have been searching, but cannot find an explanation for this.

anyone have experienced this before?

Thanks

Hi, I had something similar happen with the 7" TS and TouchUI not loading up properly. I found that some of the files were missing:

http://www.mystoopidstuff.com/blog/getting-octopi-014-working

Mine boots to the TUI with no problem till the log in screen. but my screen is black, until I move my mouse.
I took a video and the a screen capture. Hopefully this will give a better idea of my issue.
If I stop the TUI, I can see the texts from booting up

Edit:
The same if i load the desktop. I can only the the wallpaper when i drag and select with the mouse cursor

Pic is a bit messed up, I dont see a video, but guessing you can launch chromium then? Unfortunately is has been a while since I had this problem and don't recall what I saw as far as the desktop, but I do recall that it was just pretty much hung at a black screen with a prompt. Looks like you got further. Just for giggles, you may want to check that there is a touchui directory here:

/home/pi/TouchUI-autostart

Other than that, have you tried the t/s steps here?:
https://github.com/BillyBlaze/OctoPrint-TouchUI/wiki/Setup:-Troubleshooting#boots-to-blackscreen

I cannot attach the video.
here is a link https://imgur.com/a/l9ivZBr
Yes, the TouchUI folder is on the Pi, see attached "RPI list" pic

Boots to Blackscreen
I have tried this, but i get stuck here:

  1. Run sudo nano /etc/X11/xorg.conf.d/99-fbdev.conf
    if file/path does not exist then create it
    The file opens, with [ Directory '/etc/X11/xorg.conf.d' does not exist ] at the bottom middle

  2. i copy and paste the lines as this was a new/blank file
  3. Save & Exit (CTR-O, ENTER, CTR-X)
    When i press CTR-O, I get this message:
    [ Error writing /etc/X11/xorg.conf.d/99-fbdev.conf: No such file or directory ]

and that is where I get stuck

Obviously Im new to all of this and probably missing something simple :)

Hi, thanks for the video, that is a different problem than I had, but even so, I checked mine and although I have touchui working I don't have that file either...or the directory, which I think is the problem.

"[ Error writing /etc/X11/xorg.conf.d/99-fbdev.conf: No such file or directory ]"

but that directory is not in /etc/x11:

pi@octopi:/etc/X11 $ ls
app-defaults xinit Xreset Xresources Xsession.d
rgb.txt xkb Xreset.d Xsession Xsession.options

But then I found this:
https://unix.stackexchange.com/questions/176870/etc-x11-xorg-conf-d-missing

So I checked /usr/share/x11 and found them:

pi@octopi:/usr/share/X11/xorg.conf.d $ more 99-fbdev.conf
Section "Device"
Identifier "touchscreen"
Driver "fbdev"
Option "fbdev" "/dev/fb0"
EndSection
pi@octopi:/usr/share/X11/xorg.conf.d $

The contents of my 99-fbdev.conf is different than the one on the BillyBlaze page, but it works for my 7" (official) Pi T/S. You may be able to find the file in /usr/share/X11/xorg.conf.d , and see what it has, then do the same steps. I am not sure if it matters if it is in /etc since mine does not have it there and it works, but if you have it in /usr/share/X11/xorg.conf.d and running the steps does not work, you could try and copy that directory over to /etc/X11/xorg.conf.d/ (which again I do not have either).

HOWEVER, so you know, I just fumble my way through problems like this and by no means an expert, so this could be barking up the wrong tree even. I's suggest imaging the SD if you are otherwise working and want to have a backup.

What am I missing here? I cannot even find /ect/... nor /usr/share/X11/xorg

This is what Im getting:

pi@octopi:~ $ /etc/X11 $ ls
-bash: /etc/X11: Is a directory
pi@octopi:~ $ /usr/share/X11/xorg.conf.d $ more 99-fbdev.conf
-bash: /usr/share/X11/xorg.conf.d: Is a directory

This is what is on the Pi
pi@octopi:~ $ ls
mjpg-streamer scripts
Desktop Music Templates
Documents OctoPrint TouchUI-autostart
Downloads oprint Videos
LCD-show Pictures xinput-calibrator_0.7.5-1_armhf.deb
matchbox-keyboard Public

did a "cd"
pi@octopi:~ $ cd /usr/share/X11/xorg.conf.d
pi@octopi:/usr/share/X11/xorg.conf.d $ ls
10-amdgpu.conf 10-quirks.conf 45-evdev.conf 99-fbdev.conf
10-evdev.conf 40-libinput.conf 99-calibration.conf 99-fbturbo.conf

and this is what is inside:
Section "Device"
Identifier "touchscreen"
Driver "fbdev"
Option "fbdev" "/dev/fb1"
EndSection

So ill do the change from fb1 to fb0 and cross my fingers

Happy days!!
seems to have solved the problem!
No more black screen
now to get the virtual keyboard working

Thank you very much for the assistance!

Awesome! Thanks for letting me know (good info to have in case I run into it when I update). BTW, is all you did was change the following in /usr/share/X11/xorg.conf.d/99-fbdev.conf ?

Section "Device"
Identifier "touchscreen"
Driver "fbdev"
Option "fbdev" "/dev/fb1" << changed this to "Option "fbdev" "/dev/fb0""
EndSection

Did you need to do anything in the /etc/X11/xorg.conf.d/ directory?

Thanks!

yep, that was all I did changed fb1 to fb0.
Now it sounds so simple, but it only took me 4 hours ... lol!

Thanks, may be a good idea to let "BillyBlaze" know since I bet you are not the only one that doesn't have that file in /etc (I don't).

Seems to be the way it always is, the smallest things are the biggest headaches :D

Also, I think when the BillyBlaze pages says "if not found, paste the code into the fileif found, replace /dev/fb1 into /dev/fb0 or /dev/fb0 into /dev/fb1" he probably means to edit the file 99-fbdev.conf and swap the values. For example, I have "Option "fbdev" "/dev/fb0"" so if I had a problem, I would try "Option "fbdev" "/dev/fb1"" (note the "" around these would be removed).
Thats the way I read that at least.

(nap time)

Thanks QuentinT. A good Thing! I'd show it with my white iPhone in it... but then I'd have a hard time taking the pic! It fits perfect.