Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Customizer not working for me

Please Login to Comment

I use thingiverse for some time but now I realized this app "Customizer". I could imagine that it would be really great to have things / designs which could be customized. So I tried to open a thing in Customizer, but it do not work. I get the message "Oh No! There was a problem communicating with Thingiverse. It is also possible that you are using Safari, if so click the Safari Fix button then reload this page."

I try Customizer on Windows 10 with Chrome.
I allready have googled around but only found some really old posts which seems to be solved long time ago. I also tried an other browser (InternetExplorer). What could I do to work with Customizer? Is there a general problem with Customizer at the moment?

Thank you for every hint / answer.

I am trying to post a scad file from OpenSCAD and the customizer says.
"We're sorry! Something went wrong."
I am on Chrome and Win 10. Is there anything that can be wrong in the scad file ?

@mildmojo: Your advice solved my problem with Chrome. After adding "customizer.makerbot.com" to the browser's cookie allow list (www.thingiverse.com was already there) I could open the customizer app even in Chrome.

Hoorah! The cookie trick worked! Finally getting to try customizer in browser!

Lads! There is a bug on the website I presume, the customizer works as soon as you PUBLISH your thing. It does not work when the Thing is not published. Maybe something to do with the Customizer app not being applied to an entity that is not 'live'.
@thistof Glad the cookie thing worked. I tried doing that but it worked only when I published my Thing.

Gonna cross-post from the comments on my parametric lens tripod mount because nobody's explicitly laid it out here yet:

I can usually get past the "Oh no!" page by turning off ad blockers and enabling third-party cookies in my browser, but last time I had to add "https://customizer.makerbot.com" to my browser's cookie allow list. In Chrome settings, under Cookies, there's an "Allow" section where you can manually add "https://customizer.makerbot.com" and "https://www.thingiverse.com", which might let you get past that error. In Firefox options, you can do the same thing on the Privacy tab if you click the "Exceptions..." button.

Parametric Lens Mount Ring

I had that same error initially with Chrome on Windows 10 - just needed to enable cookies for customizer.makerbot.com and it works for me.

Even in my experience Customizer does not work with Chrome. But with Explorer it works, even if it reports the error "Oh No! There was a problem ..." you have to reload the page.

Customizer is the worst! Just don't use it!

I used it just once and for weeks afterwards my Thing folder was spammed with the same crappy thing, generated by Customizer.
Likewise other people have used Customizer to open a OpenScad file, that I published, and had the same experience as myself. There are currently 48 identical remixes of the Thing, "Published" by just two people.

If possible I would advise you to open the customisable files in the program they were created in and not use Customizer at all.

Agreed, customizer doesn't seem to work on any browser on any OS for me. Don't be intimidated by OpenSCAD, it's really very simple once you spend a few minutes with it, so put on your DIY hat and get into it!

Thank you for your advice. Perhaps it is really simpler to edit scad files directly. I did not think about that because I am not that familiar with OpenSCAD...

The latest openscad has a builtin customiser style UI - which makes it easier to use on existing scad files generated for customizer

I got this message when trying to run OpenSCAD. " WARNING: Can't open import file 'C:/Users/b****/Downloads\OpenTab1.stl', import() at line 47"

@budge72 Not sure if this thread is the right place for your question.
The openSCAD file you have loaded is looking for a pre-exisiting stl (3d model file) called OpenTab1.stl.
That file must be something specific for whatever the scad file is you are opening. I suggest you try to find that file wherever you got the scad fie from...
or comment the line out in the scad file and try it again.
Just in general be sure to be using the latest version of openSCAD.

I figured it out right after I posted this. Thanks for following up. I just wrote a post on the thing I was trying to customize to help others figure this out. If anyone else is lost on how to use OpenSCAD's customizer locally, read my post here https://www.thingiverse.com/thing:3511396/comments .

Slack Lack Parametric Magnets

http://www.openscad.org/downloads.html be sure to scroll down to the development snapshots section.

Use the development snapshot 2018.01.06. You have to enable the option under Edit > Preferences > Features > customizer

Aha! There it is. Thanks.

Truly awesome advice @Neon22! Just download the scad file and its very easy to customise it...

I have managed to run the customizer app on Internet Explorer. It seems to depend on configuration of cookies. Allthough I allowed cookies in chrome for "www.thinigiverse.com" it still does not work with chrome. But after looking on the source code it is not that important to have some nice dropdown menu ;-)

Thank you for your help.

@Neon22: One last question: I am using openscad at version 2015.03-2 which should be the latest version. What do you mean with "customizer style UI" in openscad? Do you mean the text area on the left half of the program area or have i overseen something probably deep in the menus? Googling about that only delivers me links to "makerbot customizer on thingiverse"...

Use the development snapshot 2018.01.06. You have to enable the option under Edit > Preferences > Features > customizer

Looks like a windoze build is not yet available. but soon hopefully.