Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Micromake D1 Repetier Configuration file

by Lucidwolf

I while back people asked about upgrading Repetier versions for the Micromake D1 and I said I would post my configuration file and then forgot for about a month.

WARNING: The micromake utilities in the Cura 15.0 provided does not recognize my machine after I updated. This was fixed by my own code (Easy Delta Pie) at https://www.thingiverse.com/thing:2528507. The most important part auto level works. Run it a few times to home in on the correct parameters for level. I had to drop work on it for Otto Firmware. Maybe end of year I will finish the code and call it production ready.

Note: This is just the configuration file because i didn't want to give the whole compiled firmware in case people didn't have a heated bed etc.. I wanted to force people to use the configuration site to verify their machine options. I run a very vanilla Micromake D1 with heated bed.

INSTRUCTIONS:
Down load the configuration file at https://gist.github.com/LucidWolf/65175d8145f6cacb119e1cdc67b336f7
Then head over to https://www.repetier.com/firmware/v092/ and upload that configuration file.
Then step through all the options and set up your printer as you like. (This is setup how I run mine that is vanilla with the heat pad option.)
I highly recommend if you are new to Repetier firmware to look through all the options available.

Once you are happy with the selections the last tab allows you to download all of the firmware.
Extract the downloaded firmware and open it in Adruino IDE:
Select the correct COM port
Select the Mega 2560 board
Select the Mega 2560 Processor
Compile and Upload.
I cant remember if you need any fancy libraries...
Good news is most setting for Repetier are stored in EEPROM so as long as you didn't select to overwrite the EEPROM in you config file your machine should behave the same just have more menu options.

Cheers. LucidWolf

Easy Delta Pie
View Comment

MicroMake C1 - No Home Z

by kheltoz

I have a micromakeC1, many times I make a mistake of not doing home in Z, it is usually resolved (I don't know how), but not this time.
With the M119 command it says that the sensor is active, even if I disconnect it it is still active.
I have no way to print because it cannot be done home, the Z axis goes up some MM every time I do home.

View Comment

C1 hotbed issue

by dgworks

Hello, I did the corexy mod from https://www.thingiverse.com/thing:2496797
it runs well but i still having trouble enable the heat bed

can anyone help? thanks!

Micromake C1 COREXZ conversion
by Xlnt3D
View Comment

Micromake L4

by samostaeff

Всем здравствуйте.может кто нибудь помочь.Мой принтер.Micromake L4. не может загрузить систему.в чём может быть неисправность?

View Comment

Micromake D1 - skew/tilted print???

by bfince

Hi folks,
my D1 begin to print objects slightley skewed (i don't know if it is the right expressioni tilted or leaned or smth, as seen on the photos)

No change after all, same stock parts, same stock card, same slicer software, same brand filament

-checked the belt tensions, and adjusted as needed
-check the stepper pulleys if there is a friction
-checked and re-adjusted bed level
-checked first layer adhesion (it is fine, thanks to pei)
-the material is Esun PLA+,
bed temp is 55, extruder temp is 204
-delta arms has dampeners from the beginning so no serious backslash

only things that i found weird is the ball connectors on the carbon arms are loose (due to usage). I ordered new arms just in case but i can not be sure if it is the problem.

help needed

View Comment

can never get the extrusion right.

by CarsonKT

this problem bothers me a lot.
I set my micro step to 32, steps per mm to 200 and flow rate to 300
the problem is it under extrude a lot, so I calibrate it according to youtube video, I get something at 500ish flow rate.
I run the test again, the situation is like filament doesn't come out quick enough from the nozzle so I can feel the kick back at the gear
the extruder I am using is a mk8 from aliexpress...

View Comment

SD Card is Detected But no files Show up on the 3D Printer

by Brainy_Ryan

I exported my .gcode files to a SD card the Printer Detects The SD Card But The Files on it Are NON EXISTENT on the Printer

I Have Formatted the SD card Twice in FAT 32 and exFAT but It doesn't Help

View Comment

does the old v1.2 board has self recovery fuse?

by CarsonKT

I was trying to measure the current to see if the extruder motor has enough current and accidentally short the board I guess.
now only board plugged in use the screen will turn on and I can still flash firmware, but plug into wall outlet gives nothing...
I can see on the board there is a T110 and a T050 fuse, are they recoverable? if so how long it takes to recover?

View Comment

I did not able to print full size in Micromake D1

by adhanabal

Hi friends
Im having Micromake D1 Delta printer . As per their website i see its build area is 180 dia. But when i try to do it . The extractor assembly touching on the belt.. i can use build area 160 dia at max. Please help me to find why its happening.
Are you able to print 180 dia with your printer?

delta extractor micromake_d1
View Comment