Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

M33 Fio: The best software for the Micro 3D printer

Please Login to Comment

M33 Fio

© 2015-2017 Exploit Kings. All rights reserved.

Description

M33 Fio is a plugin for OctoPrint that extends its capabilities to make it fully compatible with the Micro 3D printer. Both OctoPrint and M33 Fio can run on Windows, macOS, and Linux, so this solution is the first platform independent option available for this printer.

The latest version of M33 Fio is V1.21 released on August 4th, 2017, and an entire changelog for it can be found here.

Features

  • Platform independent
  • Open source (M33 Fio's source code can be found here)
  • Supports STL, OBJ, M3D, AMF, VRML, COLLADA, and 3MF file formats
  • Allows printing multiple objects together
  • Displays an accurate representation of the printable region
  • Objects can be manipulated, cloned, cut, and merged
  • Displays an objects dimensions
  • Multiple printer support
  • Fully customizable slicing profiles
  • Accurate bed calibration
  • Supports the Micro 3D compatible heatbed
  • Firmware updating system that allows installing official and third party firmwares
  • EEPROM management
  • Webcam streaming
  • Changing filament in the middle of a print
  • Compatible with the Micro 3D open source firmware iMe

Installation

There's installers available for Windows, macOS, and Linux that install OctoPrint, M33 Fio, and device drivers for the printer and heatbed. These installers all add OctoPrint as a startup program and create a shortcut on the desktop that allows accessing OctoPrint's user interface.

If you already have OctoPrint installed, M33 Fio can be installed directly from OctoPrint's builtin plugin manager by searching for it in the plugin repository.

Usage

You'll need to disable M33 Fio's "Not using a Micro 3D printer" setting in OctoPrint's settings in order to use this plugin with a Micro 3D printer. After that you can immediately connect to a printer and start printing. M33 Fio works in conjunction with OctoPrint's auto-detect serial port and baud rate features, so neither of those values need to be specified in order to successfully connect to the printer. After connecting to a printer, all of that printer's existing settings, like backlash and bed calibration values, will be read in and used by M33 Fio to make transitioning over from M3D's official software as simple as possible.

OctoPrint uses external slicers to convert 3D object files into printable G-code, and, if you currently have M3D's official software installed, M33 Fio will automatically configure OctoPrint to use the Cura Engine slicer that comes with it. However I recommend installing the latest Cura V15.04 release so that you can enjoy all the latest improvements to the Cura Engine slicer. After a slicer is installed, printing a model is as simple as dragging and dropping a file onto OctoPrint's user interface.

OctoPrint is a web server, and it can allow remotely connecting to it. So you can open port 5000 in your computer's firewall and configure your router to route all traffic on that port to your computer to allow using your printer from anywhere in the world.

Known Issues

  • Everything works in all versions of OctoPrint >= 1.2.0 except the Micro 3D printer connection routine which only works with versions of OctoPrint >= 1.2.5
  • Microsoft Internet Explorer 11 doesn't display webcam stream since it doesn't natively support MJPEG videos
  • Microsoft Internet Explorer 11 doesn't resize slicer profile editor correctly
  • Microsoft Edge displays webcam stream as a still image
  • Can't host more than one webcam stream at a time since it always hosts on port 4999

Images

Additional controls are added to OctoPrint's control panel that allow doing everything from loading filament to updating the firmware.
alt text
M33 Fio allows changing all of the printer's settings in the M33 Fio tab located in OctoPrint's settings.
alt text
The slicer profile editor lets you quickly specify the quality and fill options of a print while still giving you the ability to fine tune every available setting.
alt text
The model editor allows manipulating the model before it's sliced. It can perform all the standard operations like translating, rotating, and scaling models.
alt text
It can also clone and import other models to allow printing more than one model at a time.
alt text
It can even cut and merge models to make even large models printable.
alt text

Troubleshooting

Q. I can't connect to the printer. I receive an error similar to, "Unexpected error while connecting to serial port: AUTO SerialException: 'could not open port 'COM13': WindowsError(5, 'Access is denied.')'" every time I try to connect."

A. Close M3D's official software if it's open, and make sure no other programs are currently using the printer. If the problem persists, then restart your computer.


Q. I receive a message similar to, "It's recommended that you disable this server's sleep functionality while printing if it's not already disabled." What does this mean?

A. M33 Fio attempts to prevent the server that it's running on from suspending/sleeping while printing, and that message gets displayed if it is unable to do so. Don't be too alarmed by this message since it doesn't mean that the server will go to sleep. It just means that M33 Fio can't prevent it from going to sleep.


Q. I installed Cura, but the slice button next to the uploaded files is still grayed out.

A. If M33 Fio detects that Cura is installed, it'll automatically configure OctoPrint to use it. However OctoPrint isn't aware of that configuration change immediately so you'll need to refresh your web browser several times for it to take affect.


Q. How do I re-open the print session if I closed the web browser?

A. Just go to the same URL that you were at before and it'll re-open the same session. You might have to refresh your web browser several times if it doesn't successfully restore the session.


Q. Even though I have the heatbed plugged in, I get an error similar to, "Warn: Not sending "M190 S100", printer profile has no heated bed" when I try to use it.

A. M33 Fio dynamically changes the printer profile whenever the heatbed is plugged in, however OctoPrint will sometimes not immediately become aware of that profile changed. So either refresh your web browser a couple of times or unplug and re-plugin the heatbed.


Q. OctoPrint's terminal shows an error about how it couldn't determine the printer's baud rate when trying to connect to the printer.

A. Something caused M33 Fio to crash, so you'll need to restart it. This can be accomplished by restarting OctoPrint, which can be done by restarting your computer.


Q. Can I use this plugin if I don't have a Micro 3D printer?

A. Yes you can. M33 Fio is already setup to be used by printers other than the Micro 3D printer by default. If you having trouble connecting to a different type of printer then make sure that M33 Fio's "Not using a Micro 3D printer" setting is enabled.

Any chance you could update the Windows installer? It's not working for me anymore and I can't for the life of me get Octoprint working on Windows from the guide on the Octoprint site... =(

Totally BUMBED out! I have a Micro+ and I just bought a raspberry pi3b+ with a lcd . Been trying to use octoprint but cannot get it to recognize the printer. Been reading here and now I know why. Hope someone will write software for the Micro+ soon.
Octoprint looks Awesome!

I am getting this error running nonstop, can anyone tell me how to fix it?

curl: (3) malformed

running macOS Mojave version 10.14

Hello
I downloaded the Windows install, but when I run the batch file all I get is an endless stream of 'Access denied'
What do I need to grant permission to?

I'm trying to install this on my Mac (OS 10.12.6) and I seem to have run into a bit of a snag. (I'm good with Macs but rarely do much with Terminal.)

I downloaded the Mac installer listed above, under the "Installation" heading. It delivered a small "Install" application that launched Terminal. In Terminal, I gave it permission to run and it did, for a while, showing its running progress. However, the progress in terminal seems to have stall for quite a while now (30mins +) so I'm wondering what to do.

If anyone here can advise, it would by tremendously appreciated. Thanks in advance!

(If it helps at all, the last thing that occurred in Terminal, and it looks like it occurred a few hundred times in a row, was:

Traceback (most recent call last):
File "setup.py", line 24, in
extra_link_args=['-framework', 'CoreFoundation']),
File "/Users/neil/pyobjc-framework-Cocoa-4.1/pyobjc_setup.py", line 403, in Extension
cflags.append("-DPyObjC_BUILD_RELEASE=%02d%02d"%(tuple(map(int, os.path.basename(data)[6:-4].split('.')))))
ValueError: invalid literal for int() with base 10: ''

I have no idea what this means.)

Question, I am running the latest version of M33-Fio on an original raspberry pi with the iME firmware on my M3D Micro. I am experiencing a strange phenomenon. Whenever I start a print I get the "Gathering Printing Information" window to pop up like normal, but while it is up the g-code viewer starts tracing the initial path without moving the printer. When the window closes the g-code stops and the printer goes through normal startup and moves to the front left corner and heats up the tip. When up to temp it moves to where the g-code stopped executing and begins there, sometimes leaving a very large trail of filament on the print bed. Has anyone seen this behavior before?

Hi All! I've had some issues getting my calibrations done well and I think I'm possibly just not understanding the verbiage used in the offset area. I have run the full calibrate and got my initial numbers after sliding a bit of paper under a clean print head so that the paper has nearly zero drag as I pull it. From there I print a 0.4mm test boarder and throw it on my calipers. Right now my #'s are (Starting with lower left and moving anit-clockwise) .10 mm, .34 mm, .45mm, .38mm

Should I be shooting for a positive or negative adjustment number (in sum) for these?!

A positive offset will make the total vertical displacement for a corner more upward away from the bed, and a negative offset will make it more downward toward the bed.

So you should set the offset settings to these values (assuming they are currently at zero).
Front left offset: 0.30mm
Front right offset: 0.06mm
Back right offset: -0.05mm
Back left offset: 0.02mm

Hi! Is the Micro+ supported?

OctoPrint and M33 Fio wont work with Micro+ or M3D Pro printers.

Any plans on supporting these in the near future?

When the Micro 3D printer first came out it got a lot of people interested in reverse engineering it and developing their own software for it. It took the effort of a whole community to create M33 Fio and iMe firmware and to refine them over the course of several years. The release of the Micro+ and M3D Pro hasn't really attracted those same kind of people so it's hard to tell if that same amount of dedication will be put toward developing software for those printers as well. I don't own or plan on buying either of those printers, so it probably wont be me who leads the effort. However I am trying to help by making sure that all of the necessary resources, like the ability to install our own firmware onto those printers, are available to anyone who wants to further reverse engineer those printers. So only time will tell if support for the Micro+ and M3D Pro get added to M33 Fio.

Also I replied to your email. I have had some issues in the past with messages from my domain name being sent to gmail's spam folder, so make sure you check there too if you haven't seen it yet.

Hey Donovan, love your work.
I have tried out the M33 Manager in conjunction with Cura. Had it running fine. Thought to check out M33 Fio. if its better. Had it going also fine. Unfortunateley after installing the Octofio package from above, or perhaps after cancelling a print in Octoprint, now my Cura won't start anymore.

Rebooted, reinstalled Cura, upgraded Cura from 15.4.2 to 15.4.6, uninstalled the Python thing and other new stuff in Software nothing solves it. Any Ideas?
Is there also an uninstall.bat for the components you install?

PS: Will write soon in the other thread how to get cura running fine with your m33 manager. Had to modify the start/end code of cura a bit. Also in your firmware printers doing weired extrusions before printing.

Edit: Solved here: https://ultimaker.com/en/community/20180-cura-stuck-on-splash-screen-log-included

"found that it helps to make the following change to Cura\util\pymclevel\materials.py"

I
From:

def addYamlBlocksFromFile(self, filename):
    if  yaml is None:
        return

To:

def addYamlBlocksFromFile(self, filename):
    if True:
        return

Glad you were able to get Cura working again. Based on the other comments on that forum, it's hard to exactly pin point what could have caused Cura to stop working. I don't really think installing OctoPrint/M33 Fio would cause any issues with Cura since Cura uses the version of Python that comes with it. I don't know for sure though since I've never experienced it myself.

What do you mean by that the printer's doing weird extrusions before printing? M33 Fio's preparation pre-processor stage primes the extruder by extruding some filament into an unused corner of the print bed and scrapping it off before printing. This can be seen at the very beginning of this video with the filament trail going from the front left of the printer to the model: https://www.youtube.com/watch?v=5S4cpM4G6vM. Is that what your talking about?

And if anyone wants to know, the matching uninstallers for OctoPrint + M33 Fio can be found here: Windows, macOS, and Linux

No, not within Fio. This works well. Cura performs some retractions at the beginning oft the print if u dont G92 E0 it.
It isnt written in the Gcode file but nevertheless it retracts. So i also added a priming routine in the start code aswell.
Also u have to start the fan within the start gcode if printing with a raft.

At this point im doing the calibration things in Octoprint. For the usability of third party software it would be cool to have the same amount of calibration options also in m33s manager.

So belows my modified start and end gcodes which work quite good. Sometimes the printer misses the m109 s{print_temperature} but if you cancel and restart it should begin. There is also a calibration routine inside remove the ;'s to get it going. I think the offset there differs from micro to micro so first check out your own offset.
In Curas preferences u can switch to "pronterface ui" printer window. Here you have more options to control your printer before or during print.

Happy printing.

start.gcode

;Sliced at: {day} {date} {time}
;Basic settings: Layer height: {layer_height} Walls: {wall_thickness} Fill: {fill_density}
;Print time: {print_time}
;other temp:{print_temperature}
;ideal temp:{print_temperature}
; Calibrate z with offset
;M109 S150
;G30 ; probe the bed to find the z plane
;G1 Z0.43 ; raise the nozzle to a height that you have previously verified is a the desired height relative to the probe trigger point
;G92 Z0 ; set this position as the new Z 0 plane
;G1 Z4 F600; raise the nozzle
M109 S{print_temperature}
G90 ;absolute positioning
G92 E0 ; Zero the extrusion length
;G0 F{travel_speed}
M106 S255
; Print prime Line
G0 F2100 X8 Y104 Z0.270
G1 F600 X40 Y104 E10.0
G92 E0 ; Zero the extrusion length

end.gcode

;End GCode
G91 ;relative positioning
G1 E-0.5 F300 ;retract the filament a bit before lifting the nozzle, to release some of the pressure
G1 Z+0.5 F{travel_speed} ;move Z up a bit and retract filament even more
G1 Z+6 F{travel_speed}
M104 S0 ;extruder heater off
M107
M18 ;steppers off
G90 ;absolute positioning
;{profile_string}

can i use this start and end code on the M3D software without the iMe and fio?

Pretty new this this, but think i got it all sorted.

Used the M33 manager and was able to connect octoprint to the printer.

I can drag and drop an stl file, but don't have access to a slicing profile. Have installed the latest Cura but still no slicing profile.

Any ideas?

There's no reason to use M33 Manager with OctoPrint + M33 Fio. Just disable the Settings > M33 Fio > 'Not using a Micro 3D printer' setting to activate all of M33 Fio's Micro 3D features.

M33 Manager is made for third party software that doesn't support the Micro 3D printer since those software don't know how to put the printer into firmware mode. So you'd need it if you were using OctoPrint without a M33 Fio.

What slicer is everyone using? I'm still using Cura I believe, but really not happy with the support material extrusion. Is it possible to use this? http://plugins.octoprint.org/plugins/slicer/ or Slic3r?

If the Front Left corner of my bed is too high, do I raise or lower the value of Front Left Orientation?

@Gecko251 Yeah I am also having problems with connecting with Octo 1.3.2 and Fio 1.17. I thought I was doing something wrong but its just not working anymore.

Anyone having trouble getting thei m3d to connect running the newest version Octo 1.3.2 and Fio 1.17?

The octoprint guys say there is an issue with compatibility, from what I just saw

Hey Brannigan, do you have that link? Having trouble finding info from them.

Comments deleted.

Never mind, I found it and looks like there is a fix now: https://github.com/donovan6000/M33-Fio/issues/216

First uninstall the Fio plugin and reboot the Pi. Then I had to download the new M33 FIo to my HD: https://github.com/foosel/M33-Fio/archive/fix/issue216.zip Install it by going into "From an uploaded archive" in the plug-in manager.

Seems to have worked.

Yup, worked for me too

Worked for me as well.

I am as well. However I have been unable to get my M3D clear to connect to either my RPi or to my desktop (Mint 17). As a result, I do not know if it is the fault of the printer or the operating system, or the kindly offered M33Fio

Great program,
however I am having problems with the slicer. Often, after placing the models and moving them and whatnot within the boundaries (red transparent things) and slicing them, the slicer offsets them a couple of millimeters in a direction (the direction varies, I think) causing my entire slice to be ruined because now the gcode has instructions outside the boundary and it wont let me print it. This causes me to have to spend more time slicing again (usually a few times) to account for the offset.
Another problem is the model viewer doesn't load at all.
When I try to use brims, the slicer completely ignores it and skips over it. It shows up in the model placer/ mover thing but doesn't slice. I have been able to use brims on some other models but on some, it refuses to load.
Lastly, the slicer causes ridges and offsets in certain spots in a print with a circular nature because of the way it slices and starts a new layer in the same position I assume. How can I prevent this?
Thanks

First of all, thank you for your effort on these projects, M3D should bring you in them team :)

Is it better to use the embedded M3D cura enginge (which I don't know what version is), or the latest v15.04.6?
What firmware do you use? (I bet your firmware :P)

I'm getting slightly different prints passing from official M3D software to the latest octo1.3.1+m33fio1.17, the first layer is thinner, but I understood that is normal because M3D software do something in the first layer that we don't know, BTW this will lead me to better calibrate the print bed, so what's the big deal then? Is the layers that don't stick so well like with M3D, but the flow seems to be more precise, this is really strange, as I read alllll these threads here, and there should be no difference passing from the official M3D software to OctoPrint+M33Fio.

So I'm asking if you would be so kind to share how do you approach to a new M3D printer?
Can you list the step you do to fine tuning your printer? How you calibrate it, what do you print to test if everything is ok, and how do you print (with raft or not, quality, etc...) I think this will really help people approach faster to this printer, or at least find faster the limits of the actual hardware they got.

EDIT1: I made another test with the M3D software, and I see similar imperfection, so I guess now is something related to calibration, so for this my last request is becoming a pray to you :)

EDIT2: and finally after hours of tries, I did almost a perfect cube, and it was the filament tension. The biggest problem I had was the filament that constantly change the pressure on the nozzle, especially after the second half of the roll, the circles becomes tight and generate a kind of a natural spring, so in this case I've loaded in the internal bowden tube, and most of the problems has been disappeared. BUT, I have only one problem now, the first 3mm of layers of the cube seems to be squeezed, in fact the height is lower of about 0.2/0.3mm, I thought it was the thermal bonding, but after disabling it, It did the same thing even if the temperature was correct. What else could be? The next layer are really really good, and I'm quite impressed!

I have to say I'm impressed. I am running this on Windows 10 with a mostly stock Micro 3d (I moved the fan to the front). So far everything is a little better. Backlash calibration is tighter for some reason, bed adhesion has been great, layer adhesion is solid, and I'm running lower temps on PLA and on Tough 3d. It connected right up. It took maybe 30 minutes to get everything installed, firmware updated, and start printing.

Next step is raspberry pi, with wifi, and a webcam

Is Linux compatible with this software and if so what versions?

OctoPrint and M33 Fio run on pretty much anything that can run Python, so it is compatible with Linux. The Linux installer that I link to in the first post only works on all modern Debian and Fedora based Linux distros, but it should be easy enough to get it working on any other distro.

Hi!
Was trying to print flexible filament and didn't get any good results. Is there an option in M33 Fio to change the flow of the filament? I was reading that bumping up flow should work...

You can try increasing the 'filament_flow' setting in the Advanced section of the slicer profile editor when you slice a model. Not many people have had much luck with using flexible filaments with the Micro 3D printer though. It seems like the extruder motor can't really grip the filament correctly.

I'm using the tough 3d stuff and it works great, zero issues. I haven't tried the industry standard filaments though.

I am new at setting this up. I got OctoPrint 1.3 working and stuff on my raspberry pi. I am stuck on the setup wizard it won't let me go any farther. Where it says under "Configure CuraEngine" what path to CuraEngine do I need to put there? i am guessing cura is already installed for the new octoprint?

You can skip the Cura Configuration part of the setup wizard if you don't know if you have Cura Engine installed or where it is at. If your using the OctoPi Linux distro then you already have Cura Engine installed. Otherwise you'll need to install it yourself.

Well I just got my m3d about a month ago and I have been using tinkercad would this program be for only advanced people?

M33 Fio is for people of all skill levels. It provides all the same slicing options as M3D's official software and more, so you can have as much or as little control over how something is printed as you want.

Having a bit of trouble getting the Windows install going... anyone tried the install recently and experienced an issue?

None of the octoprint shortcuts appear after the installation.

https://www.youtube.com/watch?v=E7KVw_bRu4I

It looks something changed about one of the server's that the installer downloads a file from, and that broke the Windows installers. We should have it fixed later today.

Thanks donovan! absolutely love your software and I honestly don't know what I'd do without it and my M3D printer!

Thanks. The Windows installer is all fixed now.

I'm trying out octoprint + M33 fio - however, not everything improved. I'm experiencing quite strong warping and especially (which is new) curling. The shapes I get are also looking a bit like they're over extruding. I'm wondering if my printer's fan is making trouble - maybe you've got a hint for me what might be wrong?

A problem I seemingly could fix is an issue where the printer would just not respond any more. From what I've seen, it looks like that the printer would not acknowledge a received command. I've manually lowered the baud rate to 19k and I haven't seen this issue again. Might be related to the fact that I use a PC-compute-stick to interface with the printer.

M33 Fio doesn't do anything to improve the quality of prints, so you should be getting almost identical results to the prints created with M3D's official software.

The curling is most likely resulting from the your bed calibration being slightly too high and/or the extruded filament is cooling too fast due to the temperate of the room.

You can try decreasing the 'filament_flow' setting in the Advanced section of M33 Fio's slicer profile editor to see if that helps with the over extruding.

I printed a test object using m3d software and m33 fio + octoprint and the results did (slightly) differ. But this is not the most pressing issue I have.

1) Random printer freeze: I still experience that the printer just stops mid print. The printer terminal suggests that the "recv" acknowledgement was not passed. I am still trying to find options that tweak the serial com port - currently it's running seemingly more stable.

2) z-layer adhesion: the prints are (and always have been) quite brittle and the layers almost don't stick together. Even thick prints part along layer lines as easy as breaking a match stick.

3) extrusion stops mid print: I had this issue also when printing with the m3d software.

I think 2 + 3 might be caused by extruder temperature issues and are unrelated to m33 fio. I am trying out m33 fio in hope to gain more information actually.

So now I'm trying out higher print temperatures: A print with 240° (PLA) looked actually quite good but still fell easily apart along layer gaps (despite not showing any visual cues that something might be wrong, it looked just perfect but when lightly stressed, it quickly broke in two halves). I am somewhat suspecting that the heater element might be blamed.

I agree that 2 + 3 are unrelated to M33 Fio. You could have a bad extruder motor, the nozzle could be clogged, the heater could be calibrated incorrectly, and/or the fan could be bad.

The random freezing could be M33 Fio's fault or the printer's firmware's fault. Try switching to M3D's V2016010812 firmware or iMe firmware and see if the random freezing persists. You can also enable the Settings > M33 Fio > "Log debug information to plugin_m33fio_debug.log" settings and upload the plugin_m33fio_debug.log file here after you experience a random freeze so that I can see what caused it.
alt text

OK; I am focusing now on the print freezing - I think the other issues come from a wrong heater calibration (I recall having layer adhesion problems at certain heights from day 1 - it simply just got worse over the past 2 months).

So now I'm making a print with the m3d firmware and m3d software that failed two times in a row with octoprint / fio. I'm actually not expecting trouble here, I used to make prints that took 6h+ without having that issue.

Once that print is through, I'm going to update octoprint, switch to m33 fio, enable the debug logs and see what the result will be. Yesterday I had quite a spectacular fail where I didn't notice that it had frozen and the extruder kept extruding plastic until it was a grotesque looking blob of about the size of a small thumb.

I would really like to use octoprint + fio as it gives me a better overall impression. I wonder what is going on with my hardware here... I remember that I had the same issues back when I used a Pi one year ago when I tried octoprint for the first time. Back then I thought it was due to immature software as it was quite new.

Here are the last lines of the terminal output of that session:

Recv: ok 21041
Recv: wait
Send: N21043 M10535
Recv: ok 21042
Send: N21044 G1 F720 X64.626 Y42.825 E1790.62663
3
Recv: ok 21043
Send: N21045 G0 F1200 X64.626 Y74.175*79
Recv: T:271.4127

... from what I understand, the printer didn't acknowledge the N21044 nor the n21045 command - though it did report the temperature as a last message. I also noticed that the printer would pause sometimes in between for a few seconds, leaving marks on the plastic as a result.

Don't update to OctoPrint V1.3.0 yet. M33 Fio has some problems with it that I'm trying to fix right now.

Ok, Your message reached me just in time!
I'm currently printing with octoprint but with the m3d firmware - and it looks fine so far, 6h+ without incident (and with maximum temperature setting - I wonder if it's possible to recalibrate the heater thermoresistor). I'll keep printing for a while with the m3d firmware for a bit longer to verify that the connection is stable.

Another question: When I slice a model through octoprint and chose not to use a raft, the bottom layer isn't sticking as well to the printbed as when I chose the same settings in the m3d options. When printing without raft through the m3d software, the first layer lines are wider and thicker. But I prefer printing without a raft... even though I have to admit that the raft improves overall quality of the result. So how can I chose to print with thicker lines for the first layer?

But anyway: Thank you so much for all your work so far!

M33 Fio V1.15 works with OctoPrint V1.3.0, so you can update to the latest version and not have any issues.

M3D hasn't release any information about how the heater's are calibrated. I have looked into it a bit, but we still don't know what their calibration values mean.

Due to how OctoPrint's Cura Engine plugins works, we aren't able to get the first layer or raft to be exactly the same as those generated by M3D's official software. You can try decreasing the 'bottom_thickness' settings in the Advanced section of M33 Fio's profile editor to lower the starting height of the print. I think the 'bottom_thickness' also affects the the thickness of the first layer, but I'm not really sure. I haven't experimented enough with Cura's settings to know exactly what all the settings do.

Sorry for the noob question. Now that all is working, if I update Octopi, will it automatically update m33fio or is there another step involved?

You can update M33 Fio using OctoPrint's builtin software updater. Just go to Settings > Software Update > "Check for update now" and it'll allow you to update M33 FIo.
alt text

Hello Donovan,

I've had an "accident" again - with the original firmware. I caught this on video: https://www.youtube.com/watch?v=mOXOflojtbo - as you can see, the print head went to 0,0 and also moved down - while extruding to filament. As this happened over night, it resulted in quite a mess. This was the first incident within 2-3 weeks. But it is quite scary as I fear this could damage the printer at one point.

The first question: Have you any idea what is going on? Why is the printer not stopping at a certain point? I would have thought that it simply ran out of commands and therefore would just stall. This is much worse...

The second question: Could the firmware be modified to make an emergency shutdown if it's seemingly stuck?

Were you using M3D's V2016010812 firmware or M3D's V2016040401 firmware. V2016040401 has been know to dig into the print bed like that for no reason, and M3D is apparently aware of the problem and is working on a solution..

The accelerometer in the printer is too prone to noise and isn't very good at detecting slow Z movements like when it's grinding into the bed to be able to reliably perform any kind of emergency shutdown. There is an emergency stop button in the General section of OctoPrint's Control tab that does immediately stop everything, however it probably wouldn't work reliably in cases where the printer's firmware has gone haywire like with what happened to you.

Hey donovan, I think I gathered some more information - though it's difficult to verify. I think my USB connection is simply unstable. I noticed that the camera connected to the same USB hub shows sometimes random horizontal stripes for one frame. Sometimes it doesn't any signs of problems, then again it's all over the picture. I also think that issues with the printer failing to accept new commands arose most often after moving the printer around and thus changing the cable (-plugs) positions.

Meanwhile I also accidentally broke my printer's nozzle and ordered a new nozzle alongside with a new fan - best accident and decision ever: After properly replacing both components, the prints are incredibly improved and more accurate than ever. I am also no longer overheating so much - while still printing PLA at 230 degrees, it's now much closer to the filament's target temperature. The fan is cooling the prints properly, producing less blob artifacts when printing spikes.

I always knew that it must be something with the nozzle and heating it... and the replacement nozzle and the silicon heater cover just seem to be the correct solution. The silicon heater cover IS actually different from my previous heater cover. I was a backer and got one of the later early models, among the last backers to receive their rewards - so I suspect that m3d later modified the silicon cover slightly to have a smaller hole at the bottom. Or maybe my old heater cover was just worn out? I don't know for sure...

Anyway, I am soon going to switch to your firmware and testing it again (I had 3 accidents with m3d's firmware in ~ 2 weeks and I tried both firmware versions available for that). Unless I see more accidents again, I'd guess that there's a fault with one of my cable / hub components.

Glad to hear that your getting better results after just replacing the nozzle and silicon cover. I had similar results when I replaced my nozzle a couple of months ago. I'm also not sure if there's something wrong with the older versions of the nozzle or if they just wear out after some time. M3D hasn't been very public about the improvements they've made to the printer over time, so we'll probably never know.

Wanted to give you a short message how it's going for me, Donovan: I've been printing now for a week with the m3d printer firmware and the octoprint fio plugin. It's been working like a charm so far, the only failed prints I had were due to adhesion or filament problems. The communication seems to be fine. I am reluctant right now to go on bug hunt now and installing your firmware; I have some presents to prepare and am very happy that it's working right now reliably for that purpose. I'll be testing your firmware as soon as I have no specific task I want to get done.

Apart from that, I decided to try out simplify 3d, however I am not convinced. The prints don't look any better, the raft removal is really bad and it's not printing any faster than with cura. It's probably the settings, but the switches I tried didn't really work for me.

Thanks for the heads up!

THANK YOU! I moved to OctoPi&M33 and it is beautiful and very convenient; and also very-very fast compared to m3d software. I really love your work, thank you once again!

Glad you like it :)

What firmware should i use? I haven't installed any - the stock m3d is installed, and i get decent prints. Should i install any that m33 offers?

If your not having any problems with the stock firmware then there's no need to switch. All the firmwares will generally produce the same quality prints.

Quick question - I have the OctoPi distribution and under the plugin manager it shows that I have M33 FIO version 1.10 installed and that 0.27 is the latest version available.
Obviously something is out of whack with where the OctoPi is looking for the latest plugin. Does anyone here know if this is something I can fix (and how) or if I have to file a bug report with either OctoPrint, OctoPi or M33 FIO?

Sounds like the cache was corrupted somehow. Try seeing if OctoPrint's Settings > Software Update > Advanced options > 'Force check for update' button fixes the issue. If that doesn't help then something other than the cache was corrupted and reinstalling OctoPi to the SD card should fix it.

So, after back and forth with this (via OctoPrint) and the official software, I finally find that I'm getting better and more consistent results using OctoPrint/M33 Fio on a dedicated Raspberry Pi print server.
I wanted to reach out and say "thanks" to donovan6000 for making this software, and also share some of how I'm getting consistent results.

  • OctoPi server (octoprint running on raspberry pi) - The official software, at least on my personal mac which also does other things at the same time, crashes occasionally, ruining what otherwise was turning out to be a good print
  • frequent calibration - tho octoprint UI makes calibration much easier. I find that I have to calibrate every 3-5 prints.
  • I've had issues with the filament getting jammed (hardware issue - affects both official software and octopi). I've started rubbing blade oil from my razor on the filament before some prints. I'll see if that helps.
  • I still use the official software for unloading/loading filiment. It places the print head in a more convenient location, and seems to do a better job of releasing the filament when there's a jam.

Thanks, donovan6000!

I run the install.bat file and the screen goes to a command prompt and then just flashes and flashes like it claims to be downloading, but never seems to actually do anything. Is this normal? Is something actually downloading and installing behind the scenes? Windows 10.

Can you post a screen shot of when the installer seems to stop? Does this happen every time you run it?

The installer.bat file is just a batch script file, so you can always right click on it and choose to edit it to see exactly what it downloads and installs.

Thanks for the fast reply. It never seems to stop. I let it run for several minutes, then I kill it, since the only % that shows stays at 0%... I'll try piping the output to a text file.

So it's this line:

    bitsadmin.exe /transfer "Python Version" /download /priority FOREGROUND https://www.python.org/downloads/windows/ "%TEMP%\index.html"
    IF %ERRORLEVEL% NEQ 0 GOTO loop1
    If NOT EXIST index.html GOTO loop1

It just keeps looping back to itself and never downloading.

But if I take this line

bitsadmin.exe /transfer "Python Version" /download /priority FOREGROUND https://www.python.org/downloads/windows/ "%TEMP%\index.html"

And run in the command prompt, it DLs the file and saves it to index.html just fine.

That's kinda weird that it works fine when you run it manually, but not when it's run from the installer.bat. It will only keep looping back to itself it bitsadmin returns an error code other than 0, which indicates that it failed, or if index.html doesn't exists, which happens if bitsadmin fails to download the file. I have tested the installer on Windows 10 and it worked without any issues, so I have no idea what the problem is.

As a workaround you can remove those lines from the installer.bat, manually run the command like you did to download the index.html file to the %TEMP% directory, and run the installer.bat again.

Tried again (after your comment this morning on the M3D forums) and found the problem. The script does not appear to take into account running from a different drive than the temp directory. My D: drive is where my downloads, data, etc. goes. The C: drive is for OS/Programs only. So the script is running on D: and does a CD to the temp directory, which does change the path on the C: drive, but does not switch from the D: drive to the C: drive as active. So the download was trying to write to temp folder on the D drive...

So I just copied the BAT to a folder on the C: drive and ran it and it seems to be proceeding just fine. :)

Hi Donovan6k,

I own a M3d printer.
First of all, compliments for all of you work, it's amazing!
I installed OctoPi on my RPi3, with m33Fio plugin. The firmware is the latest stock one.
I'm experiencing problems with the auto bed calibration, in particular with the last (and manual) part: it says to put a sheet of paper under the nozzle and lower it until I cannot move the sheet anymore. The problem is that doing this results in almost "hammering" the nozzle into the bed, and when this happens (apart from the risk of damaging the steppers) usually the first one or two layers of the print (which is usually a raft) do not print (like if there was no extrusion, but I think that the problem could be that the nozzle is too close to the bed), while the rest of the print comes out quite well: any hints?

You can increase the 'Bed height offset' setting in the M33 Fio tab in OctoPrint's settings to elevate the calibrate values. So putting it at something like 1mm will help.

Or you can perform the calibration while using something thicker, like a credit card, instead of a piece of paper.

Ok, thanks, that was my first guess :-)

Yo Donovan6000,
I'd like to try your software an IME firmware, but I'm afraid of messing up my stock setup which works fairly well. It appears that Octoprint/M33 Fio can coexist with the M3D software and one can switch between using each, correct?

Can one switch between IME and stock firmware easily? If so what is that process and is there a risk of losing important settings like backlash, etc.? I picked up simplify3d and would really like to use it with the M3D Micro.

Thanks for entertaining my noob questions.

OctoPrint and M33 Fio don't do anything to interfere with M3D's official software, so you can have them all installed on the same computer and switch between them whenever you want. However M3D's official software will constantly try to communicate with all the connected Micro 3D printers, so you'll need to make sure that M3D's official software isn't open when using the printer with any other 3D printing software so that multiple programs aren't trying to use the printer's serial port at the same time.

iMe uses all the same EEPROM addresses for the same printer settings that M3D's official firmware uses, so you wont lose any settings when switching between the different firmwares. The only exception to this is that iMe stores the extruder's Z position in the printer's EEPROM differently than how M3D's official firmware does. M33 Manager and M33 Fio will automatically convert that Z position when switching between the different firmware types so that it is maintained, but M3D's official software wont do this. So you should only use M33 Manager or M33 Fio to install M3D's official firmware.

Does this firmware auto-install itself on every boot? Or is it a "install once" kind of thing?
How does one un-install if you want to do that?

M33 Fio isn't a firmware, it's a plugin for OctoPrint. It's compatible with all M3D official firmwares >= V2015122112 and all versions of iMe >= V00.00.01.12. It'll detect your printer's current firmware every time it connects to the printer so that it can let you know if there's any updates available for the type of firmware that your currently using.

The different types of firmware can be installed using the buttons in the Advanced section of OctoPrint's Control tab. You can use those buttons to install M3D, M3D Mod, or iMe firmwares. Installing a new firmware onto the printer means replacing its existing firmware, so the firmwares only need to be installed once. Uninstalling the printer's firmware would make the printer useless since it can't do anything without firmware, so you'd install a different type of firmware instead of uninstalling its firmware.

Thanks for the reply. What I find is:

On Windows 10 -
triangles do not appear with: Edge
triangles appear with: Firefox, Chrome

On iPad -
triangles do not appear with: Safari, Firefox, Chrome
triangles appear with: nothing so far

Sections expand in all cases with a click to the left of the section label.

It's kind of weird that not many web browsers redraw the element's background when its background-image property is changed. Since there's so many inconsistencies with it, I've just decided to use other methods of displaying the triangles. So it'll be fixed in the next version of M33 Fio.

Sounds good.

(My printer comes back today!)

In your Modify Profile image, you show access to Manual and Advanced Settings. These aren't showing up for me. Is there some configuration I'm missing? Thanks.

Make sure your using a modern web browser, like Google Chrome or Mozilla Firefox. I know Microsoft IE and Edge have issues with updating the 'background-image' CSS property when it changes, and that's what I'm using for displaying the blue arrows next to each sections name so they don't show up when using those web browsers.

You should still be able to click to the left of the section's name where the blue arrow should be and it'll open the section.

I got everything working and this looks waybetter than M3D's beta software but I need to adjust my settings. I did the auto calibrations but I printed an arduino cause on high res with medium fill and when I took it off the bed it crumbled. Do I need to adjust the temp or something else? Using pla set to 215 degrees

I can't connect to my M3D, I get 'Connection error, see terminal tab', which says:

Changing monitoring state from 'Offline' to 'Detecting serial port'
Changing monitoring state from 'Detecting serial port' to 'Error: Connection error, see Terminal tab'
Unexpected error while connecting to serial port: AUTO UnboundLocalError: 'local variable 'state_string' referenced before assignment' @ comm.py:_openSerial:1553 (hook m3dfio)
Changing monitoring state from 'Offline' to 'Detecting serial port'
Changing monitoring state from 'Detecting serial port' to 'Error: Connection error, see Terminal tab'
Unexpected error while connecting to serial port: AUTO UnboundLocalError: 'local variable 'state_string' referenced before assignment' @ comm.py:_openSerial:1553 (hook m3dfio)

I've restarted server, rebootred, made sure M3D official software wasn't running. Anyone know what's happening?

This was caused by an error in OctoPrint 1.2.14. Update to the latest version of OctoPrint and it should be fixed.

Every time I update and restart it still asks me to update. Do I need to uninstall and reinstall octoprint? How do I uninstall octoprint in windows?

Run the Windows installer again and it'll update OctoPrint and M33 Fio to the latest versions.

You can find out what changes in the IME11?
Thank found itself)))

I am having a problem where when i try to connect, it just says connecting for a long time and does not connect. This is after i have let the setting of the baud rate to auto. When that setting was active a similar thing occurred where it just said detecting baud rate for a while and did nothing. At the top it does show my printer name and the plugin profile is set under the connection settings but it is still not working. I have gotten to far now to give up; PLEASE HELP.

Does OctoPrint's log show any errors related to M33 Fio? You can download the log in the log tab of OctoPrint's settings.
log

Thank you for the help, though that wasn't it. I believe the problem was that the M3D Spooler was still open in the task manager, so it didn't connect. but the log info will still be helpful, thanks.l

Try to start a formal software 1.4.2.6 and then try M33Fio

THANK DONOVAN6000 you remember about us)))))

Thanks a lot for this plugin.
I installed octopi + your plugin on a Raspberry Pi yesterday and everything are OK for the first print.

Very good job !

Don't let em get to you .. I suspect on the quiet a lot of the devs at M3D love and use this plug-in what ever the suits think.

Keep it up - don't leave us hanging dude !!!

Seriously - thanks for this - simply a life saver.

G.

So will iMe be continued and maybe support the Micro.
Thanks for everything

VERY DISAPPOINTING (((

Thanks for this awesome plugin! Just started to use octoprint and M3D Fio for my printer, the change from M3D software is huge. My printer just went from a piece of crap to gold.

Keep up the good work :-)

If anyone wonder witch firmware to choose:
I recommend using the V2016040401 firmware. The new iMe firmware was not any good for my printer.

What is the best air gap measurement for rafts? I'm trying get to the official software perfection on the raft. I did do a full calibration through Fio and printed at .3 mm and .5mm at 205 degrees Celsius(standard Hatchbox temp for me). And my own z axis calibration at .3mm, .5mm, .7mm and still get rafts that are hard to remove. Also using wave form/bond if that matters, it doesn't on the official software.

I changes the raft airgap in the newest M3D Fio V0.31 to 0.35mm since someone said they got better results with it. Someone was testing out some raft settings here if you want to try them.

First THANK YOU for this! Yesterday evening was the first time (over a year now) this printer makes fun and give me time to look for a new 3D printer ;)

but... I have a strange issue I coundn't explain to me?!
The printer stop nearly 2 sec before he move to the next printing point.
hmm you can I explain?! He prints very well as long as he had not to move the head without printing.
my this video explain more what I mean:
https://onedrive.live.com/redir?resid=9E27A47D0F78C5A7!18385&authkey=!ABJSKgd5oXpiR48&ithint=video%2cmp4
(do not be irritated by the strange sound, that was my 4 months old son who wanted the mobile phone ^^)

so a 3 hour print needed 8 hours... :/

with the orginal software he printed without that halt.
I use firmware V2016012501.

That's due to the retraction settings in the slicer profile. When the extrude moves over a gap it'll retract the filament slightly to prevent stringing. You can disable retraction or reduce the retraction amount to speed up those delays.

You are my hero of the month! ;)
Thanks a lot!

thank you for posting this just got a M3D like a week ago and kinda hate the software it came with. I got this set up late night on my laptop and i love it.

Help! I broke it. :P I tried to upgrade to the latest M3D-Fio, but when I restarted, I was no longer logged in to Octoprint. The login button didn't do anything; I entered my credentials and clicked and it just sat there doing nothing, so I couldn't get into the interface to get it to connect to my printer or access the plugin manager, or anything. So I decided I had messed it up beyond repair, and figured I'd just start over and reinstall Octoprint, but I no longer had the original install package I had downloaded, and the OS X installer link in your original post in this thread gets me an installer.zip file that can't be unpacked.

I was actually finally getting close to getting my prints to look decent. :(

[Edit]

I found the installer I used the last time, and tried running it. Here's what I get with it, now:

curl -o ''"$TMPDIR"'installer.sh' 'https://raw.githubusercontent.com/donovan6000/M3D-Fio/master/installers/OS%20X/installer.sh'
Last login: Wed Mar  2 23:48:48 on ttys000
sudo sh ''"$TMPDIR"'installer.sh'
exit
Ruths-MacBook-Air:~ geek2nurse$ curl -o ''"$TMPDIR"'installer.sh' 'https://raw.githubusercontent.com/donovan6000/M3D-Fio/master/installers/OS%20X/installer.sh'
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100     9  100     9    0     0      1      0  0:00:09  0:00:05  0:00:04     2
Ruths-MacBook-Air:~ geek2nurse$ sudo sh ''"$TMPDIR"'installer.sh'
Password:
Sorry, try again.
Password:
/var/folders/27/31xswfp17ds78g801qzgr73r0000gn/T/installer.sh: line 1: Not: command not found
Ruths-MacBook-Air:~ geek2nurse$ 

I renamed the installer.sh to install.sh, so the older installers wont work. I just updated the first post at this thread to include the newest links to all the installers.

It's probably not your fault. It sounds more like there's an issue with M3D Fio's JavaScript. Can you help determine what error it is by right click anywhere in OctoPrint and choose the option similar to 'Inspect'. That term changes depending on the web browser that your using. I think it's 'Inspect' in Google Chrome and Microsoft Edge and 'Inspect element' in Firefox and Safari. This should open a new windows that'll tell you any JavaScript errors that it encountered.

Here's an example of what this looks like in Google Chrome. The error is in the bottom right corner. Also what web browser are you using?
alt text

I'm using Safari.

I'm so confused. I thought, since I had uninstalled Octoprint last night (I ran the uninstaller, anyway...) that I'd better go ahead and reinstall so I could find the error per your instructions. So I downloaded it from the link in your post, and this time it unpacked properly, but when I ran it, I got this:

Ruths-MacBook-Air:~ geek2nurse$ curl -o ''"$TMPDIR"'installer.sh' 'https://raw.githubusercontent.com/donovan6000/M3D-Fio/master/installers/OS%20X/install.sh'
sudo sh ''"$TMPDIR"'install.sh'
exit
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  6195  100  6195    0     0   1243      0  0:00:04  0:00:04 --:--:--  1254
Ruths-MacBook-Air:~ geek2nurse$ sudo sh ''"$TMPDIR"'install.sh'
Password:
Sorry, try again.
Password:
sh: /var/folders/27/31xswfp17ds78g801qzgr73r0000gn/T/install.sh: No such file or directory
Ruths-MacBook-Air:~ geek2nurse$ 

But when I tried opening localhost:5000, just in case, there was Octoprint looking all happy, with the M3D stuff and me already logged in, and everything. Maybe it just needed a good night's sleep? :P

However, when I click on the settings link and go to the plugin manager, I'm back to the "pip command could not be found" error.

I'm gonna go reboot and try again. I'll let you know if anything changes.

[EDIT]

My computer has gremlins.

After rebooting, and reopening Safari, I'm back to the problem with the login button not working. I can't see the image in your message (it looks like a broken link) but when I right click on the login button and choose "inspect element," I don't see anything that looks like a javascript error. There are 10 errors saying things about "failed to load resource; server responded with 401 unauthorized", and there are 254 CSS warnings about invalid property declarations and unexpected tokens...

So I tried opening it in FireFox, thinking maybe I'd find the javascript error, and discovered the opening screen is entirely different in the two. Here it is in Safari: (https://www.dropbox.com/s/e8flczugjsvj2bz/Screen%20Shot%202016-03-03%20at%207.59.11%20AM.png?dl=0)

and in Firefox: (https://www.dropbox.com/s/rz6kynudsqdr3tz/Screen%20Shot%202016-03-03%20at%207.59.27%20AM.png?dl=0)

Firefox allows me to log in, and I can go to plugin manager and see that M3D Fio 0.28 is now installed. (I don't know how, since it sure looked to me like it didn't work!)

I can upload screenshots of the Safari "inspect element" stuff if you want me to, but at this point I can't tell whether it would be of any help to you!

It's my fault the installer/uninstaller didn't work. I forgot to update the Apple scripts to use the new file names, so both the installer and uninstaller were running nothing. It's all fixed now, but you don't really need to use them since you already have OctoPrint and the newest M3D Fio installed.

OctoPrint's 401 unauthorized errors tend to happen when the web browser tries download files from the server without sending the current authorization key. The web browser will cache the previous key and use that, so refreshing the web browser a few times should eventually load the page correctly. Once your not seeing the 401 errors anymore, then check the page for JavaScript errors again.

Okay, thanks again for all your help, I'm happy to know it wasn't all my fault. :)

Has anyone successfully set this up in OS X El Capitan, to run from the desktop? I've got an Octoprint webloc icon on my desktop, but connecting to localhost:5000 gets a "Can't connect to server" error. I tried it using 127.0.0.1 instead of localhost, same results. Obviously I need a Web server enabled, but I've got no experience doing that on a Mac, and no idea really where to start. I also don't know if this is something the installer was supposed to do for me and failed, or whether I missed the psychic instructions informing me that I needed to set one up before installing Octoprint. Help?

I have not. I hardly use my mac book pro 2011. but you could use windows in parallels. if you need a windows key... if your are taking a cite program or really any computer class at a college you should be granted access to dream spark where you can get windows for free. and windows runs amazing on osx with parallels. just a thought

It should work fine on all version of OS X >= 10.7. Can you run the following command in the terminal so we can verify that OctoPrint was successfully set as a startup program?

cat /Library/LaunchAgents/com.octoprint.app.plist

And does running OctoPrint manually generate any errors?

~/Library/Python/2.7/bin/octoprint

The first one generates this: (not sure how to post xml stuff here, crossing my fingers and just pasting it in!)

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

Label com.octoprint.app ProgramArguments /Users/geek2nurse/Library/Python/2.7/bin/octoprint serve RunAtLoad KeepAlive

========================================================================
The second one does this:

Traceback (most recent call last):
File "/Users/geek2nurse/Library/Python/2.7/bin/octoprint", line 5, in
from pkg_resources import load_entry_point
File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pkg_resources/init.py", line 3084, in
@_call_aside
File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pkg_resources/init.py", line 3070, in _call_aside
f(*args, **kwargs)
File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pkg_resources/init.py", line 3097, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pkg_resources/init.py", line 651, in _build_master
ws.require(requires)
File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pkg_resources/init.py", line 952, in require
needed = self.resolve(parse_requirements(requirements))
File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pkg_resources/init.py", line 839, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFoun

Ugh. If you can point me to the formatting commands for the forums here (haven't been able to find them yet!) I'll try to make that look better...

Also there might be a chance that the installer failed when downloading one of OctoPrint's dependencies, so you might want to try running it again.

This forum used the same Markdown formatting system as Github, so you can use that to better format displaying commands. I understand what you posted though, so don't worry too much about it.

Can you run this command.

~/Library/Python/2.7/bin/octoprint --version | cut -d' ' -f3

And it looks like the the important information got cut off or you didn't post it. There should be a packages name right after the last 'pkg_resources.DistributionNotFoun' that'll tell us what needs to be installed for OctoPrint to run.

Oops, it looks like I did cut off the last bit. Here it is:

File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pkg_resources/__init__.py", line 839, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'psutil==3.2.1' distribution was not found and is required by OctoPrint

And here's the output from the new one:

Ruths-MacBook-Air:~ geek2nurse$ ~/Library/Python/2.7/bin/octoprint --version | cut -d' ' -f3
Traceback (most recent call last):
  File "/Users/geek2nurse/Library/Python/2.7/bin/octoprint", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3084, in <module>
    @_call_aside
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3070, in _call_aside
    f(*args, **kwargs)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3097, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pkg_resources/__init__.py", line 651, in _build_master
    ws.require(__requires__)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pkg_resources/__init__.py", line 952, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pkg_resources/__init__.py", line 839, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'psutil==3.2.1' distribution was not found and is required by OctoPrint
Ruths-MacBook-Air:~ geek2nurse$ 

Some network issue occurred when downloading psutil, which probably caused the rest of OctoPrint's dependencies to not be installed. Run the installer again.

Ohhh, I'm so close! Octoprint comes up now, and it's beautiful, and I SO want to use it...but it can't connect with my printer. I get this:

Unhandled firmware error
The firmware reported an unhandled error. Due to that OctoPrint disconnected. Error: No more baudrates to test, and no suitable baudrate found.

[Edit]

Re: The above, none of the M3D software is running, and I've restarted my system since killing it all, so that shouldn't be the problem.

When I was bumbling around in Octoprint and the Wiki trying to see if I could figure anything out myself, I discovered I'm also apparently missing the pip command, according to Octoprint's plugin tab. I found this online about installing pip: (https://docs.python.org/2/library/ensurepip.html) but I have no experience with any of this and don't want to make things worse by trying to fix stuff I don't understand, so I'll wait for your expert guidance. ;)

It almost sounds like M3D Fio didn't get installed or isn't being initialized by OctoPrint. Your running into a lot of installation problems for some reason. Is there a Micro 3D printer in the octopus's crystal ball like in this image?
alt text

And you have already have pip installed. It's at /Library/Frameworks/Python.framework/Versions/2.7/bin/pip. If you restart your computer, OctoPrint's plugin tab will automatically detect that location.

It's my years of karma coming back to haunt me, from my old tech industry days and all the eye-rolling and cynicism about "stupid users" that I used to engage in. Now that technology has completely passed me by, I'm getting to experience the "stupid user" end of things. sigh They're right -- karma's a bitch! :)

Anyway...my octopus is holding an M3D printer (that's awesome -- I hadn't even noticed!)

I figured out how to reinstall the M3D Fio plugin, and in the process also upgraded PIP to the latest version, restarted everything, and now it's detecting my printer--YAY!!!

Unfortunately now I have to get ready for work and will have to postpone the joy of my first Octoprint print. :(

Thanks for hanging in with me -- I will keep you posted!

any luck yet? I just started trying to pull this of and I am getting the same issue on windows and mac. login wont do anything after reboot

It sounds like your web browser is using a cached version of OctoPrint. Try refreshing your web browser a couple of times to see if it fixes it. If that doesn't help, then verify that OctoPrint was successfully added as a startup program. To do that in Windows verify that there's the following registry entry in HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run.
alt text

To do that in OS X run the following command and post the output here.

cat /Library/LaunchAgents/com.octoprint.app.plist
Comments deleted.