Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Bricked My Machine Please Help :(

M3D_Micro_Plus

Please Login to Comment

I've spent days designing a model for a contest to win the newest M3D machine. It wasn't printing. During a firmware update it disconnected and now I am getting the "invalid firmware" disaster.
Is there anything I can do?
I need to get these printing now if I'm going to enter the contest.
I have the Micro+
I am BRAND NEW to printing and was finally getting the hang of things. This makes me so sad. I've only had the machine since December.

I have tried...
A different computer
uninstalling the software
installing older versions
etc
I am getting bootloader code B007 (whatever that means)

Thanks in advance!

Hi Missy-I have had the same issue. If it's not too much trouble, can you tell me what you did to get it to work?

Any luck figuring it out?

you could try using the m33 launcher and use its install firmware option.
id even recommend the custom firmware over the original as it lets you use 3rd party software but you can use it to install an older stock firmware
https://www.thingiverse.com/groups/m3d-the-micro-3d-printer/forums/general/topic:6479

Ask in Discord - but most likely, you'll be asked to create a ticket with their support, so you may as well go ahead and do that.

Ask your question here to get the quickest, definitive answer:
https://discordapp.com/channels/279255051036524544/286562086002098176

The M3D employees are in there all day and that is the channel for troubleshooting your computer.

Yay figured it out! haha, Learning a lot of new things today.

Please let us know how to solve the issue. It’s driving me insane trying to fix it

What did you find out? I'm now getting B007 too - no connection! Help!

Hi!
I joined Discord but cannot seem to find the channel. I think I need an invite or something?

I dont know about the M+ but I used the original M3D for my first year of printing a couple years back and I had the same issue. I resolved it by manually flashing aftermarket firmware with donovan6000's custom iMe M33 from Github and it worked so well I never returned to the stock firmware. I havnt a clue if anyone has taken his path in supporting the M+ (i know HE finished a stable release for the M33 and posted he was finished with any future work in the Micro). I will try and look around to see what I can find. Maybe there is some stock firmware out there you can manually flash back to the mainboard like I had too.

Thank you!
I look forward to finding out.
I did read a lot of the boards on the custom iMe firmware but, it might as well be another language. I will definitely need a walk through if it's possible haha!

iMe doesn't work with Micro+ (or Pro), at least not yet.