Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

OctoPi in the A5 - Step by Step

JGAurora JGAurora_A5 OctoPi Pi Camera RaspberryPi

Please Login to Comment

If anyone is curious about installing a Raspberry Pi running OctoPi and Pi Cam inside their A5, I've posted a video on YouTube on how to do that. It's pretty detailed, and longer than I wanted it to be, yet I still managed somehow to leave some points out. So read the comments section as well for additional tips from me and my viewers.
https://youtu.be/yR-B14vWdZg

Hi. I have problems installing Octoprint on a JGAurora A5S. Every time I start a print, the RPI sends too many commands without waiting for the "ok"s. So it enters in "checksum error" and the printer sends "re-send command". Anyone installed Octoprint in a JG A5s successfully?

You might try upgrading the firmware. There were bugs in earlier version with the USB Printer port:
https://jgaurorawiki.com/a5s/firmware?s[]=a5s&s[]=firmware

Thank you for your reply. Also the latest Official Firmware (17th june 2019) has this problem. However I tried flashing the Custom Community firmware and it works quite well. Now it works with Octopi. So the problem is on the JGAurora official firmware

if you connect your octopi to the mks mainbord , you will loose fillament runout senor, becaus this is connected to mks tft.

...as I stated in the video.
But actually, as you state it, that's incorrect.
Just connecting the OctoPi to the Mks mainboard won't cause you to loose power recovery or filament sensor. Printing though the OctoPi, just like printing through your PC will bypass those features.
However, you can still print through USB memory stick and monitor and control via OctoPi without losing those features.

How to slice stl on raspi via octopi?

After setting your printer properties in OctoPi, just upload an STL file to it and the web interface will ask you if you wish to have it sliced for printing.
I really don't recommend it, though, OctoPi is using a 2 year old version of Cura and it and you don't have much control over the slicer as compared to Cura on your PC.