Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Up-to-date Marlin firmware for the Aurora A5

Please Login to Comment

Hi all,

Stay tuned for more A5 firmware updates, we are actively working to get this open source. Currently working on getting the filament sensor to unload and load as expected.

I love feedback and collaboration, so please feel free to help it along!

https://github.com/GilardiLabs/Marlin/tree/JGAurora-A5

EDIT: We've released a solid firmware. See link above.

***NOTE: Please make sure to have a backup of your firmware (or JG's original HEX file) before proceeding with this. I take no responsibility for errors or issues, though I am here to help if I can. :)

Is this firmware that you're making better than the community firmware I already have that I got from the unoffical wiki?

i just got the printer and it did not come whit instructions and i am still working on calibrating everything but since this is my second printer idk much because the 1st one basically was all set to go soo what should i do 1st?

Just got my A5 yesterday and came home from work, popped in the 7 screws and followed all the destructions and it won't move along any of the axis. All connections are tight, looks as though they "upgraded" things and hot glued them all in place. I can get the bed and extruder to heat up, I can feed filament all day long into a nice spiderweb under the head... but it won't move.

I've tried several things I found online including updating the firmware and it still doesn't even home or move... tried using pronterface to no avail either. I noticed others having problems with endstops so here's my report...

Reporting endstop status
x_min: open
y_min: open
z_min: open
filament: TRIGGERED

There's no filament loaded at the moment and even when there is, I get the same msg that the filament sensor is triggered.

Any help would be appreciated before I have to admit to my wife that I spent a big chunk of money on a paperweight.

is this the A5 or the A5S? from what i've heard they look the same, but the 5S is a bit harder to upgrade.

Sorry, I don't get alerts on thingiverse, so I didn't see your reply. Did you get this sorted?

The filament sensor being triggered is not important... ignore that. The filament sensor is connected to the LCD, the main motherboard has no idea of the status of the filament sensor.

Can you please post on the facebook group, or on the forum (jgauroraforum.com) and I can try to help you there with a faster response time.

For starters, you can run the M119 command while pressing each of the endstops to check that they are working (they should all say triggered if being held down during the command). But if the printer won't even try to home, then its not a problem with the endstops.

Hi..Mgilardi,
I need your help, just bought the A5 2 months ago. Honestly I can say I do not know how to updates the firmware for my A5. Do you have any guidance to me step by step the procedure how to upgrade the firmware?

Thanks in advance...

Hi Kureka,
I have written the whole process here: http://jgaurorawiki.com/a5/firmware
and I have made a video here: https://www.youtube.com/edit?o=U&video_id=ZE0siGAvZNI
Good luck,
Sam

Just got my JGAURORA A5 this morning from GEARBEST didn't think i would get it was so cheap or i would have a hefty import duty charge, but got delivered fine, no charges and only took 8 days, also looks like i might have got the upgraded version with removable blackdiamond glass bed plate, feels very solid, even the white panels on the sides are stuck in place nice and solid, have noticed that the blackdiamond plate surface scratches off very easily though where the metal clips hold it onto the aluminium bed, so concerned about that, i had better not use and metal scrapers on it, but at least in the future it can be replaced with the anycubic Ultrabase plate as its removable, looks like the same type of surface, also might upgrade to a thicker aluminium bed in the future too as this is very thin, not like the 3mm beds available. but extreamly happy so far, although not switched it on yet. lol

I would just like to say thank you Samuelpinches for doing all the hard work and tweaking for us all so we can just flash and go to get the best out of the machine from the start, very much appreciated.
Big Thanks :-)

Thanks Rick - I hope you can get the most out of the printer! ;-)
The firmware was a team effort, I'm proud of our community! If you have any questions or problems, feel free to join us on the forum (https://www.jgauroraforum.com) or the facebook group. Best,
Sam

Thank you my friend...
Thank you for your effort..

Hope God bless you all...

Kureka..

I updated to the this firmware but now my printer will only home in the + direction. So once one of the axises moves in the + direction thats it, there's no going back.

Any ideas?

(I'm brand new to 3D printers, the A5 is my first ever)

Firstly, a warm welcome!!

Move or home? Homing is the initialisation movement that moves an axis until an endstop switch is triggered. This is how the printer references its positing - from the home point. You need to do a homing operation on all axis until the printer will allow you to move the axis across the full range.

If homing doesn't solve your issue, let me know and we can troubleshoot further. :)

FYI... small update to the firmware coming soon, with much more accurate temperature calibrations than used in both the previous version, and in the factory firmware.

Homing is the issue. If I revert back to stock homing works fine.

Basically when I press home with marlin the printer will only move all the axises in the positive direction so z goes up x goes left and y goes back. They all move about an inch in the respective direction and then stop. In the move screen it shows the z at 0. It’s a really weird problem to have and not sure what could be causing it. Again if I revert back to stock using hex file homing works as expected.

Edit: https://m.youtube.com/watch?v=w_tIaigZFcw

I suspect something is going on with either a mixed up cable somewhere, or a loose connector. You can check endstop status using pronterface and gcode command M119. You can also trigger homing using gcode command G28, or use the buttons in pronterface. Pronterface gives you a log of output from the printer motherboard, and it might give you some clues as to what is going wrong.

M119
SENDING:M119
Reporting endstop status
x_min: open
y_min: open
z_min: TRIGGERED
G28
SENDING:G28
echo:busy: processing

So after seeing this if I hold down the z switch it goes into the open position so it seems like the switch is reversed for some reason with the marlin firmware. If I hold it down and send G28 it will try to properly home.

So that explains Z but X and Y wont move at all in the negative direction after the pressing the home button, X and Y are in the position of home but I think with marlin firmware this printer is convinced everything is opposite. This could be because of whats going on with Z but technically it thinks its homed without Z being in the way.

I can't tell if this is cabling or something this A5 doesn't like about marlin. When I revert back to stock firmware homing and movement works fine. By any chance would you have a picture or a diagram of where things should be plugged in?

Since the z endstop is triggering when pushing the z switch, it is not a mixup of the endstops, it sounds like it is just a wrong wiring on the z endstop switch itself.

It sounds like a mistake in the wiring for the z endstop. This printer uses “normally closed” switches that break the connection when triggered. It could be that the z endstop has been soldered wrongly as a “normally open” endstop. Can you please disassemble the z endstop and examine it closely - there should be three metal contacts on the switch, and if you can tell me which two of those three are being used, I can check my printer and compare.

Yeah I can do that either tonight or tomorrow.

However, I do want to say this: I reverted back to the old firmware with the hex file I got from this group and its working fine. The console output now shows something different, but homing works flawlessly, so the wiring could be incorrect but it doesn't make sense that the stock firmware works fine unless its figuring it out on its own.

This output is with none of the switches actually physically pushed on. I homed everything and then backed everything off so none of the axes were physically triggered and ran the M119 command. Its interesting that with the stock firmware its reporting a min/max while on marlin its only reporting a min. Just keeps getting more bizarre!
Send: M119
Recv: Reporting endstop status
Recv: x_min: open
Recv: x_max: open
Recv: y_min: open
Recv: y_max: open
Recv: z_min: open
Recv: z_max: open

BTW I appreciate you taking the time to help me with this weird issue.

No worries, happy to help. :)

That really does sound like the sensor is incorrectly connected, but I don’t really know why it is still working on the original firmware. If you would rather try a software fix first:

In the custom firmware, in the file “configuration.h” you can try and change the line:

“#define Z_MIN_ENDSTOP_INVERTING true // set to true to invert the logic of the endstop”

“#define Z_MIN_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop.”

Well I feel silly - I figured out my issue.

Let me tell you a story:

I was trying to be a super cool nerd and instead of downloading a zip package off github I decided I would clone the repo instead. However, I was assuming I was downloading the A5 branch thinking it was the master but instead was not. So the entire time I was uploading the 1.1.x branch. I figured this out when I was looking though the config.h file and it seemed right with the bed sizes and few other indicators. I decided to get on the terminal and take a look at something and when I popped in it showed me I was in the 1.1.x branch and I immediately proceeded to bang my head against a brick wall (figuratively of course). So after uploading the correct branch, the printer seems to be working perfectly now.

End of sad story.

Thanks for taking the time to try and help me, I do wish I caught this stupid mistake earlier before commenting but whats done is done.

Doh! Glad you found the issue :D

Aaaannnnddd the weirdness continues!

I think this machine is going to have to be part of Ripley's or something!

I cracked open the case tonight and everything looks okay as far as all the connectors go on the main board. They're all keyed so if they are inverted it would have to be the pinouts on the cables.

So I had to set the inverting to true for all axises. This now posed a new "problem" which I'm beginning to think is the main problem to begin with. The directions of the servos are also now inverted. So after looking though the configuration.h file I found the settings to invert the servo direction. After that homing seems to mostly work the way it needs to. On the old firmware the trigger for x y did some kind of offset when it hit the switch. So now in Marlin the x y stops at exactly when the switch is triggered which causes the nozzle to be off of the bed and in mid air. Also, the directions on the interface are now reversed as well for x y only. So if you press +y its physically going -y.

Of course this isn't the only "issue" which I could've lived with. Now when doing the "auto" leveling the directions are correct, however it doesn't go as far as it should, it'll be about 2-3 inches in further than it normally would. Trying to manually move from there doesn't work, its almost like the auto level feature is also doing some kind of homing (this is just speculation as it feels that way)

I guess at this point I can try and just home and then manually move the axises around to do the leveling. My only concern is printing. So far I haven't been able to print anything except 1 benchy and 1 half of a money cat model which is what triggered me to start looking at firmware upgrades in the first place.

That’s bizarre! Can you please try homing from a computer using USB cable? Eg using pronterface or similar?

Hi Michael,

I managed to get the firmware running from stock marlin very last night, and I found for enabling the filament sensor you just need to increase the prevent lengthy extrude setting in conf.h. I used the Arduino serial monitor to observe the output from the motherboard when I pressed the remove filament button, and noticed it stated an error about a lengthy extrude. Hence the easy fix.

https://www.dropbox.com/s/1jlrlz9p0og5yz6/JGAurora%20A5%20-%20Marlin-1.1.x.zip?dl=0

Edit: latest JGAurora A5 firmware on the JGAurora wiki (http://jgaurorawiki.com/a5/firmware).

Cheers,
Sam

does new marlin now work for the A5?

@pinchies Good call! Thanks, Sam. I changed the value on the GitHub branch to 1000 like you used.

Hi all,
Just got my A5 and not very impressed with the quality yet.
Anyway,

are both the firmwares the one and the same (th one sam has on the wiki and the one on the github page)?

At the moment, yes they are.