Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Hotend temps swinging wildly

HE0 HE1 thermistor

Please Login to Comment

Couple of days ago I noticed the temp being reported by the hotend thermistor was 10 degrees colder than the bed temp. Printer was sitting idle overnight. I had something to print, so I ran the job, it printed fine, no issues with temp.

Printer sat overnight again, next morning the temp was reporting at 3C, too low for the hotend heater to even turn on. It wasn't 3C in my office, it was 17C. I checked the connections by moving them around, the only reaction I got was from the thermistor right at the block, it would gain 4 or 5 degrees just by lightly touching the wires where they are at the screw. I wasn't touching them long or firmly enough to pass heat from my finger to the block, making the thermistor to report the increase.

I used my finger to get enough heat into the hotend to allow the hotend heater to turn on. I had to hold my finger there until the bed heated up, and the hotend heater turned on. Once it turned on and heated up to a point that I could remove my finger. I was waiting for it to hit 185 so I could use my pyrometer to check the temp and see if this was impacting the hot temps as well. Specifically looking to see if the hot temp was also off by 10 degrees. Something new happened, the temp was going past 185 to 191, then dropping down to 179 and repeating over and over.

I was planning on changing over to the thermistor that is inside the 3mm tube anyways, so I took it apart, changed it over, and also changed the heater as well. Put it back together, and noticed right away the temp was the same for both bed and hotend. I started it up for a print job, and saw that the temp was still swinging between 179 and 191. That prevented the print job from starting.

Since the thermistor was new, and was reporting the same numbers as the original one was, I figured it can't be that, the heater itself can't shut the power off it was receiving, so it can't be the heater, I am using a MOSFET, as well as a separate LED, and the LED on both the MOSFET and the one on a panel I have plus the one of the motherboard are all responding the same way. The LED on the panel is connected directly to the HE0 on the motherboard, along with the signal wire to the MOSFET. The only thing I could think of then was maybe the HE0 connections. Loosened the two terminal and removed the wires, inspected the wires with magnifying glass(I'm old and suffer from CRAFT). Could not see any issues, and looked at the terminal block on the motherboard. The one terminal appeared to be broken, I could not get the wire to go back into the opening. The little block inside that captures the wire wasn't moving.

I edited the pins_MKS_SGEN_L.h file and changed the "#define HEATER_0_PIN P2_07" to "#define HEATER_0_PIN P2_06", and I also changed the "#define FAN1_PIN P2_06" to "#define FAN1_PIN P2_07", simply because I didn't know if the first change would cause an issue or not. Saved the changes, rebuilt the firmware and deployed it. I sent M502, and then M500 to clear the EEPROM of the previous firmware. I moved the wires from HE0 to HE1, and ran the printer. I am now using HE1 connector and the result was the same.

Here is what I get now:

Temp is set at 185C
The LED on the MOSFET, control panel and motherboard are on steady until 183, they all start flickering rapidly, temp goes past 185, LED's goes out at 187, temp climbs to 191 before falling slowly. Once it hits 185 the LED's start flickering rapidly, temp continues to drop to 183, LED's are on steady now, temp continues to drop to 179 before starting to rise again. Cycle continues up and down, print never starts due to this.

I have tried about all I can think of. The printer was working properly up until the thermistor showed a temp too low to start the heater. That part is fixed, the temps are being reported correctly now, just not staying steady.

I need to power up the bed using the E1 because my onboard mosfet is not working.....But I'm trying to find the "#define HEATER_0_PIN P2_07" on pins_MKS_SGEN_L.h, but it dosen't have, would you help my?

What version of Marlin are you using? If it is 2.0, and you are using PlatformIO, in your PlatformIO,ini file you should have a line that defines the "default_envs". In my setup I have this set: default_envs = LPC1768 . The "LPC1768" id is used in the file folder structure to locate the correct pins file. In my case this means the file you are looking for is located "Marlin\src\pins\lpc1768\pins_MKS_SGEN_L.h". The attached screenshot shows where file is located.

Why are you still using Win 7?

The Win 10 upgrade is still freely available. The only difference is that its no longer a seamless upgrade. Just go to the Microsoft website and download the upgrade.

I run the Cube on Win 10 with no issues... well yes I have issues but they're printer issues and nothing to do with the Operating System or interface.

I have been running Win10 since it was in its developmental beta stage. Don't know where you got the Windows 7 idea from.

Did some more looking and found Autotuning PID for both hotend heater and bed heater. Ran it on the hotend heater and it made it a lot better, it still goes above and below the desired setting, but only a couple of degrees, total swing of 5 degrees. It was 12 to 17 degrees prior. I have no idea why it would decide to require this initially. I could understand if I had of changed the heater and then it started to swing the temperature wildly, but nothing was changed. If it was the thermistor doing it, it should have worked properly after swapping it. I am not a fan of not being able to understand something. Here is the command line I used for the hotend:
M303 H0 S255 C10
After it ran I pasted the results into the configuration.h file.

I then ran it for the bed heater:
M303 H-1 S85 C10
After it ran I pasted the results into the configuration.h file and rebuilt the firmware, uploaded and reset the motherboard.

I then ran M502, followed by M500. I also ran the G28, followed by G29, and then saved the results of G29 into EEPROM, M500. Printer is back working again.