Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

CTC Dual Bizer ll USB problem

Please Login to Comment

Hi All

New here but i'm in desperate need of help. Ive had the above printer for nearly 2 years now and it has been running fine without any problems.

I blew the motherboard on my PC the other week and after finally getting everything sorted i turned on my printer with no response. Was a simple blown fuse so replaced it and the printer booted up.

Everything seamed fine but when i tried to print from Simplify3D I couldn't find the com port. I started looking in the device manager but couldn't find anything, I assumed it was because I had installed the New Mb in my PC so I tried my laptop and still nothing. Both are running windows 10 64bit

I've checked and I can still print from the SD card (Not my preferred choice as it too much hassle) and everything works fine, so it would appear the the fault lies with the USB port.

Is there anyway that this can be sorted out or is it a case of replacing the main board? I've seen a few posts but everyone seams to have problems with changing boards over so not sure of the options.

A step by set guide would be handy

Thanks

Rob

okay, let's try stupid stuff first...
have you any spare USB cables to test? or tested that cable on another device to see if the cable is good?
the Dual Bizer is the same replicator clone that goes by many names, so changing the board, if you need to, isn't normally a hard job, but I like to see if there is anything wrong that can be fixed first.

Do you have a multi-meter?

Yes I’ve tried both leads I have on my cnc router in the garage and both work fine. I do have a multi meter, normally only use it to check continuity so I’m no expert with it

Okay and that's fine. I was thinking of using the multi-meter to check and trace the USB ports power but.. I'm thinking you would probably need to get to the underside of the board, which means undoing the screws to remove it from the frame..

I haven't got a board to hand right now.. do you know what type of main board it is on the printer? I'm expecting a Mightyboard Rev G clone but it might be an E...

What I'm thinking is, whatever blew your PC Motherboard, blew the fuse on the printer. So a power spike took place. the Printer works fine APART from the USB port. So I would say something between the USB port and the main chips and processor probably blew too. There are some resistors. the two power (+v and ground) of the USB female run on the left side of the port, ground closer towards the port itself and +v at the back.

The power goes, I think right to a capacitor next to the 16mhz crystal (rounded rectangle silver bar ^_^). the Schematic says.. it's a 100nF capacitor (Labelled C24). If there was a spike, might be worth checking that to see if it's blown.. Is the top flat or with a bulge, is the base flat against the board, can you smell any ozone or seen any charring marks around it..
[EDIT: I'm an idiot.. it's a Surface mount capacitor.. could try using the multi-meter to see if there is continuity]

from there, the port basically (cutting it a little bit short) goes into the ATMega microcontroller chip.. I doubt it would have gone wrong there, else I doubt the printer would work

Hi tempy

Thank you for the advice. I’m not sure which board it is but I’ve attached a couple of photos.

I checked out the capacitor at c24 and got no continuity at all so I presume it’s blown. Would it just be a case of replacing this? My de soldering isn’t brilliant but I’ll give it a try

yeah, I would say that's a Mightyboard rev G clone.

basically, for testing a capacitor, with a multi-meter set to (depending on your type) capacitor mode or 1k ohms, the value should be able to get up to a value. for an analogue meter, the needle should rise as the charge builds (from the probe), which isn't much different then how digital ones can test.. basically, no continuity normally means it's bad.

problem is with soldering stills.. well.. this is an surface mount, so De-soldering isn't TOO hard... if you got some braid (I have problem getting that stuff to work right) or something, that'll help.

mm,. is that microcontroller damaged? … might just be a bit of dirt.. doubt it's damaged.. kinda.

I'm debating if just that would be fine or would there be something else to do... it might be worth looking around cause there are repair shops and stuff which can deal with electronics.. There is a place in Nottingham you can send off they'll repair boards.. depending on the board, it's a bit cheaper and much quicker then a totally new one. I like to go with the idea 'if it's broken, you can't brake it even more can you?' but.. while it might be a pain, it does work via SD so the printer does work still...

I keep going back to that MP.. but yeah.. I would say that the capacitor is blown.. but you might have to replace that chip too.. or some other bits.. if you have or can get some 100nf capacitor to replace it, it's not like it's gonna do any MORE harm.

I'll point out fully that I'm someone that experiments a fair bit not a total expert ^_^ you don't happen to have any junk electronics laying around you can practice some skills on? never hurts to try to improve your soldering/de-soldering if you aren't sure in yourself.

Yeah I’m willing to give it a go. Don’t have any are capacitors though so will need to order in. Had a look on eBay but can’t find anything that looks like this 1. Also looked on cpc Farrell but no look there either, can you make any suggestions on where to get them from. Can you also let me know the name of that place in Nottingham. I’m only in Leeds and go past 2/3 times a week

Thanks

I'm not quite sure where abouts It is there.. I'm in the south east in a complete cultural and technological backwater.

you can look on places like e-mail for getting the bits online.. always annoying though..

I think this should be fine on Cpc:
https://cpc.farnell.com/avx/08055c104kat2a/capacitor-0805-0-1uf-50v/dp/CA07633?st=100nf%20capactor

100nf is 0.1uf, that's clearly a surface mount too.