Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Stepper driver issue?

Please Login to Comment

After printing many hours the last week, I ran into some issue I can’t put my finger on;
The extruder is sometimes underextruding (ruining a 7+ hour print) and when loading filament it starts with the normal amount of filament to get less and a clicking sound comes from the stepper motor and spring loaded feeder. While clicking you can see that the filament is being hold back and sort of bounces. I had clicking issues in the past that came from a clogged nozzle or PTFE tube. This is not the case now as both the nozzle and tube are new and all other parts are clean. As I only use one extruder I already switched the stepper motor, the stepper driver on the Mightyboard and the cable from the board to the stepper motor. Temperatures seem OK.

Searching the net for similar issues, with a solution, came out blank.

Could it be that the stepper motor current calibration is off? However, the Mightyboard doesn’t have potentiometers to calibrate.

Anybody have any idea to get me going again?

Thanks in advance.

Hi Willefg,

I had a similar problem the other day. Here are my findings.

1st: The metal cog in the extruder area was loose. I pushed it back into place and tightened the little torq screw inside it. Making sure that it was screwed onto the flat part or the stepper motor shaft.

2nd: The weight of the spool was too heavy for the extruder to pull the filament into the extruder (A 3kg spool). I printed off a filament holder that sits on top of my machine so gravity can assist. I also put a guide in my spool hole so that the spool bar is central inside the filament roll. It now unrolls evenly. ( May replace a bearing one soon).

3rd: Temperature. I was printing at 220 degrees C. Aswell as stringing issues, the extruder was getting blocked. I have now dropped it by 5 degrees C. All is looking good now.

4th: Settings. I had totally forgotten that I left the extruding on 0.002 instead of 0.02. One quick change and I was all good to go.

Every now and then I'll unroll a little bit of slack just to help my printer out.

I hope that I have helped out in some way.

Regards

Robert Daniels

have you tried testing the heat? the clicking sound is basically, well for me in my experience, because the filament isn't soft enough to feed through smoothly, so it might be a case that filament isn't to the correct heat. now, if it's still at the normal heat you do and interesting it by say 10 degrees doesn't work, it might be stepper but seams odd, BUT if it does fix it, then it might be the thermocouple is starting to 'wear out' (I'm not quite sure what it does to it.. something to do with the transference of the current which is used to judge the heat or something) so you might need a new thermocouple. either way, try to interest the temp and see what happens.

Tempy111, thanks for your input. I had already checked the temperatures. I only print PETG for 3 years now and the settings were perfected over time. In the meantime, I did some more research and solved the problem. I took off the cooling fan and made a slowmotion video of the stepper movement. That clearly showed the feeder wheel to skip back. I already switched the motors, but also changed the thermocoupler. Problem didn’t go away.
Finally, I tried a larger MK10 nozzle instead of the standard MK8 with the same 0.4mm tip opening. That solved the problem, it’s back up and printing very nicely.

FYI, I have used MK10 nozzle for years, but with the latest Aliexpress order I got MK8’s and moved back to what was standard when the CTC was deliverd. MK10 nozzles have worked very well for me but as the threaded part is a bit longer I had to cut them shorter on a lathe.

mm.. if the cog is clean then I would wonder if it needs tightening up on the feeder wheel..
bigger inside diamenter of the mk10 nozzle sounds like an interesting idea.. so good ^_^

I tried thightening but that made it worse and it would damage the filament too much. I’m also puzzled why this happened now. Of course, it could be a bad nozzle batch where the opening isn’t accurate and blocked the throughput.

After looking to order some more of the larger nozzles, I’m actually not sure they’re MK10’s since MK10 spec show M7 thread instead of M6 for MK8. Wrench size for the larger ones is 10mm, for the standard (smaller) 8mm. I’ll have to look further to find the same models.