Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Introduce yourself

Please Login to Comment

Please introduce yourself and join the club. Let's use this club to share configurations, mods, updates and anything else you have been doing with your CL260 3D Printer!

Hi all! I recently bought this kind of printer and I'm having difficulty with the electronics, and the heated bed, so far I got it powered on when the bed is not connected, but when I connect the bed, there seem to be not enough power to get the display give me any output whatsoever, I followed all the connections according to the manual so, I wonder if there could be another way to connect it? moreover, I would like to know if there's an updated version of the firmware? because the ones I've found in this forum seem to upload to the Arduino but I don't get a response from the printer. Any help would be greatly appreciated.

Hey EinarV,
nice to hear that there are still other people using the CL-260. You could have opened a new topic for your issue.

Also got my printer with the heating bed back then, it came with a 12V power-supply for the printer controls (motors, divers, arduino, ramps, display). Although a pcb with relay (SLA-12VDC-SL-A) was included to control the heating bed, it was stated that I have to get a separated 24V power-supply for the heating bed (the one they deliver would not pass customs).

The Bed, will be controlled either with a relay (SLA-12VDC-SL-A) or with a mosfet (there are special high power versions for heat beds).

As power-supply for the heating bed you need something that is capable of delivering 100W (think this is the power the heating bed can take), with the calculation 100W/24V = 4.16A some come to the conclusion that you need a 24V5A power-supply (I assume you got the same bed I did, otherwise make sure your bed is capable of taking 24V and 100W).

Regarding the firmware, the one in this forum runs perfectly fine, if you want the latest firmware you can also get the latest marlin 8bit and modify it ("configuration.h"), although I would not recommend this since it can be quite time consuming and complicated to get things running.

Best,
Fabian

Hi Fabian,

Thanks for the quick reply, indeed I could've created a new topic but frankly, I haven't take my time to see around all that one can do in Thingiverse, anyhow thanks for the guidance, as a matter of fact, the SLA-12VDC-SL-A PCB was not included with my printer any idea of where can I find it? the bed I got is this one (200W 12V):

https://www.amazon.com/dp/B01H01O8AY/ref=pe_825000_114731780_TE_item

So the question is, would I be sorted out with a power supply that provides 200W 12 V for the whole printer or do I have to install two power supplies separately?

I add a picture of the power supplies that I'm trying to make my printer work with, I think both of them should do, but so far only the lenovo turns on the fans and that's it :(

It showed just once some error through the display regarding the heated bed and that's because it wasn't connected properly but once I did, everything just shut down, as if it detected a device which required more power than the output provided.

I'm gonna try to get the PCB SLA-12VDC-SL-A in the meantime, thanks again for your pieces of advice.

Sry for the late response,
regarding the pcb relay, this should be the right thing: https://www.amazon.com/dp/B01G4OA3CA
If you replace the regarding MOSFET (or add a heat-sink) for the heatbed line you may also be able to get along without relay and a separate device.

If you have a power supply that can handle that much power (pretty rare), there is no need to use two power supply's.

You should be able to use both power supply's to drive the printer without heat bed (the bed should be off by default). Both power supply's are not able to drive your heat bed (ampere wise and the lenovo also voltage wise).

I actually just got mine a few weeks ago. got a couple prints done.

got my firmware updated to 1.1.1

then one of my end stops wires died, got that fixed, now my relay for my hotbed went to crap, Mosfet on the way.

hopefully I will be printing again by Wednesday when my mosfet comes in from Amazon

Hi there, I built few of these cl-260s and found them to be truly great value for money and am very happy with the print output. Unfortunately when in transport, one of my printer's acrylic bed broke, the one which connects the z-axis rods and centre screw to the hot bed. Can provide picture. Anybody knows where can I get this spare part? Many thanks for reading this!

I can provide when I get back home today.
Have you applied any updates?

Hi all,
Glen here from the US. I have the CL-260A, with an upgraded 12v-30a supply. I'm using the 24v psu supplied and it seems fine for now but my only experience so far has been with PLA.

After many pitfalls, as experienced by most here (y-Axis) I finally figured it out. My original few prints were great, then the usual with a clogged nozzle, blown output transistor on the heater output of Ramps. Replaced my belts with more compliant ones.

I been having problems reading from the SD card. I stated I had a card in but when I went to read it, it showed an emplty dirve. I did the usual things to no avail, but I did finally realize the problem was with my Ramps1.4 board not the card slot/display controller or firmware. It did not pass the signals to the smart adaptor. I changed the Ramps board and it started working but is flakey during longer runs. Now I'm providing an internal 5v-10a supply to the barrel connector of my Arduino board as I believe that has been the source of my glitches. Wish me luck.

I hope there are others out there who are still interested as the posts seem to be spaced far inbetween.
PS The chinese site on Aliexpress has seems to shut down. The CL-260 is not listed there anymore. Any info??

theres no stupid questions just stupid answers... but great finally a group on this so easy to build and mount...
i seen this guy on you tube making it a f.,.4567g hit i saw his and thought to my self bloody hell why doesnt mine loone like that...i vill post some pic so son finished mount just the belt cant get them tight enogh

Hi Folks, I'm Andreas from Germany and plan on building a Clone from the Clone oft the UM2 :) The idea is to get quality mechanics in germany an electronics from China and rebuild the cl-260 max

Welcome to the group !
I'm now waiting for the parts to update my 260 MAX.

If you have any question we can help please just post it here.

Hi would anybody be able to help me out? I tried to update the firmware on my cl260 yesterday with this file: http://www.thingiverse.com/thing:1760728

After flashing it with this XYZ on the screen are flashing on screen & if i try to run autohome I get lots of juddering and z axis judders but doesnt move but there is tension on the motor. If i try to print (i know it won't but trying different approaches) I get a heating error please reset message.

I tried to reinstall the the original firmware: http://www.thingiverse.com/thing:1635830/#files but am getting a compiling error in arduino.

im sure this new firmware just need tweaking for the printer but i have no idea what to change to get it working.

Lastly this printer was working before the update,i only did it because my models were not printing in the center of the bed so I thought this might fix that problem.

Thanks

Cl-260 Firmware for MKS-Gen V1.4 / V1.3 and DRV8825
cl-260 standard firmware (outdated!)

Hey Sir.

First stupid question, which board are you using? Marlin or MKS?

Second since you got the X Y sound (juddering), I will suggest to unlock the pulleys and loose a little bit your belts, and align again with the alignment printed parts.

For the heating message on the screen I suggest configuring the nozzle and heat bed PID.
http://reprap.org/wiki/PID_Tuning

Do you have pronterface ? if not installed and after uploading the firmware test it through it the movement and if everything is ok then you try to home the axis one by one (With the hand on the plug in case it goes to a different place)

Let me know if you need anything else? Help with the firmware and etc.

Dont know what the boards are neither have the make on them. the mega 2560 has no name on and the only distinguishing names on the other board are robotale and ramsp1.4A

The juddering is on x & y but this is when it reaches a side,its like it doesn't register hitting an endstop,actual movement is fine. Z seems stuck when trying to autohome but moves freely when the machine is off and worked fine before the update its like it cant decide if it wants to go up or down so just stays still.

I dont know what pronerface is but I shall go educate myself on this now.

As I said the machine was running almost perfect it just wasn't starting in the center of the bed,I feel like I opened a big can of worms trying to perform an update!

But thanks for taking the time to help out!

I managed to install another version of the firmware from here: https://github.com/SirGeekALot/Marlin/tree/8710fc9b0480cf0588866f8b71b8071575f39383

I believe this guy does go on thingiverse he was the only person I could find that had his printer working when i got mine.

The printer now appears to work as it did before but still judders a bit once it hits an endstop but Z axis is working correctly,unfortunately it doesnt seem to have a driver for the SD slot so Im still unable to print anything until i manage to fix this issue.....I will find a version that works for me!

Hi Sketchy,

I changed the Y axis endstop in Marlin configuration.h file.

I had the same problem (manually triggering the endstop registered when I manually moved the y axis, so the endstop was working fine, but in autohome the y-axis just kept going. For some reason the Y-axis endstop is set to MAX - I'm sure it was supposed to work and I've configured something else incorrectly however changing the #define Y_HOME_DIR 1 to #define Y_HOME_DIR -1 fixed my issue and now the printer works just fine.

// ENDSTOP SETTINGS:
// Sets direction of endstops when homing; 1=MAX, -1=MIN

define X_HOME_DIR -1

define Y_HOME_DIR 1

define Z_HOME_DIR -1

Could be worth a try.

Comments deleted.
Comments deleted.

Hi All,

I've just assembled my Cl-260 and am wondering if anyone else has had some of the same issues as me (and if so, what kind of upgrades did you use to fix/replace some of the standard parts):

  1. The AC/DC adapter has worked for about 4 hours of testing/configuring (while I was testing endstops and axis directions etc.) but no longer works and gets very hot quite quickly (no voltage coming out of it when measuring with a voltmeter). Has anyone tried a standard PCU out of a PC to power this printer. I'm also interested in combining the heated bed and rest of printer 220V power chords so I only have one for the printer.

  2. I had issues with the Y axis direction. The endstop was working when I tested the Y axis alone (it moved in both directions and stopped moving in one direction when the endstop was triggered), however when using the autohome function, the printer ignored any endstop trigger (I've read that you need to change the direction in the Marlin firmware - which I've just done, but need to get power working to test this). Did anyone else have this issue?

  3. Has anyone tried the latest E3D hotend - (with 3mm bowden). I'm considering upgrading asap but haven't decided on what feeder to use. (it would be good to hear if anyone has had success with hotend/extruder replacements).

Thanks for any of your comments :)

The AC/DC board that came with it didn't worked for me at ll. About using the PC PCU if it delivers 12v that will work ok. Oh needs to be at least 9A

About the Y directions, I had a lot of issues with it. It started working nice but my prints were mirrored all the time ( I tried everything suggested). Then I installed Simpliify3d and I unchecked the inverted axis in the confs of the software and no more mirrored parts . Weird for me at least but worked.

I bought the new one, but couldn't install yet because I'm still printing some updated parts to the printer.

Things that I'm updating/updated are:

  • GT2 Belts
  • 20 Tooth Pulleys
  • New parts from Soren
  • Auto level Sensor (I'm using BLTOuch)
  • Updated the firmware of my RAMPs to Marlin RC7
  • Will have a new Z rod with copper nut
  • I changed all my endstops to mechanical ones
  • bought a silicone mat to change the one I have already .
  • I will by a new board MKS GEN 1.4v with TMC2100 drivers (Someone in the german community did and it looked an awesome improvement)

If I remember anything I will let you know.

Good to know. I'm getting an old PCU that should work just fine. I'm going to play around with the Y axis in Marlin and re-flash.
I'm really interested to hear how the new hot end goes so post an update if you remember!

Just purchased my CL260 and have to wait for it to arrive. What mods other than printing new plastic parts should I do? Thanks! can't wait!

Hi, I have all STL files for all parts. and original firmware if needed.

then post it here.

I posted them...

my CL-260 was delivered a view days ago, and i am looking forward for "ready to print"...some parts are missing but since now i was able to get the parts from other sources...
will report if i am finished and printing

regards from Germany Hessen Wiesbaden

Hey Boys :)

I bought one of these a couple of weeks ago. Hit me up for spare part files.

hey .

Hope you are enjoying it.

There are some spare parts in this group and others in the thingiverse that I didn't had time to associated all.

Hi,
I bought this printer on Monday and awaiting for delivery. This will be my first 3D printer. Wanted to check with you guys, how long will it take for the supplier to ship the item? since it's already been 3 days and he didn't ship the item yet. And once shipped how long will it take to reach US?

Hey...Congratulations
I live in Canada and it took to me 8 days to the supplier submit it to me and more 6 days to arrive (after the shipment).

Please remember to send them a request for a 120v (24v) instead of 220v for the heat bed because they sent me a 220v and now they are sending the 110v version plus a better relay.

I bought 12V / 24V dual voltage power supply to replace the ones came with the printer,

so that I can have only 1 power cord.

it says each voltage gets 5A each, hopefully that's enough.

Interesting. Just be aware that if you update to a Silicone heat bed (which I did) you will need at least a 24v with 12,9A only for that!

hmm, really? I thought the heatbed was rated 24v 7amp.

I bought the one from Keenovo and they told me that.!

Hi,
i am nosrev from germany and i love to tinker in my free time. I ordered a CL-260A - my first printer - and i am quite impressed of the price and the quality.
In the first week i managed to clog my nozzle, clog my hotend screw, melt my hot end cooler plug, waste half of my filament with overstretched belts, several times crash my ramps 1.4 before i noticed it’s the interfering 24V power supply (for heatbed) and burned the linear voltage regulator of my mega2560.
With some modifications and some readjustments the print quality now equals the quality of my first print. ALL of the mistakes were caused due to MY misbehaviour and happily could be FIXED :)

I am currently printing with cura with two profiles:
Default one with heatbed set to 70°C : https://www.dropbox.com/s/rjnr8m9nal0sa1n/mod_default_210_70.ini?dl=0
More detailed, but bad setup : https://www.dropbox.com/s/j8oljsu5ka39bls/good_but_not_nice.ini?dl=0

Things i already have exchanged:
Nozzle
Hot end screw
Hot end heat block
Lm1117 5V (linear voltage regulator)
All Cooler plugs (Thank you NerdFoodGames for the link)

Things i plan:
3D printer bumpers
Wall support
Exchange bearings (already ordered some from china)
Glass for hot bed

I know there are already Communities (e.g. 3d-druck-community.de), but i am quite interested to hear about all experiences.

Since this page is one of the biggest (growing) 3D model gallery it's is a great Idea to share configurations, mods, updates and anything else!
I am looking forward to hearing from you guys.

Best regards,
nosrev

What is an exchange bearing?

He meant that you should change the bearings for the 688zz for example.
;)

Nice to meet you nosrev,

The 3d-druck-community.de is a very good source for all the information (I'm using the G Translator there) related to the Cl260 Printer.

Here is the things I already bought but didn't arrived yet to update my printer:

  • Relay SSR 40A
  • Silicone heat bed 10x10
  • Springs
  • Endstop Mechanical limit switches
  • Full Metal Nozzle
  • E3Dv5 Stainless Steel Throat 1.75
  • Aluminum Support bed 10x10
  • ball Bearings for the RODs
  • Earth Neoydime Magnetics

I will also be planing to implement the auto level for the bed with the BLtouch / Inductive sensor.

Question for you how much time do you spend calibrating and leveling the bed?

Thanks
NerdFoodGames

Hey NerdFoodGames,

thank you for your reply. First had to look up all these exciting things :D
Why you need a new Relay? Because of the click you hear, every time the default switches on and off?
Why do u need an endstop mechanical limit switch? You can set the min/max values of the axes.
I guess by Full Metal Nozzle you mean just a normal nozzle/hotend set? (e.g. http://www.amazon.de/dp/B00V5W00RU)
Keep me up to date concerning you heat bed modifications, sounds quite interesting!

The BLtouch / Inductive sensor looks amazing, but i guess it's is quite complicated to integrate it in the working system (programming etc.)?

In my case i won't change something in the near future concerning the heat bed, since everything is working fine. Normally i calibrate and level (this means readjusting the 4 bed screws & z end stop screw ?) the bed only after i disassembled something at the hot end. For that i take a vocabulary card: Under every corner it should be movable but with a slight resistance "the ultimaker style" ;) This takes me ~1 Minute.

I am printing with 210°C PLA and 70°C head bed preprocessed with glue stick and when cooling down (under ~45°C) you can slightly hear the PLA contract (nothing damaged), after that you can easily remove the print without a spatula or bigger force!

Things i already ordered:
PLA:
Transparent PLA (nice quality) http://www.ebay.de/itm/281761552627?var=580765545440 (local germany)
Transparent PLA (on the way) http://www.amazon.de/dp/B00NG69UCE (amazon germany)

Replacement parts (not default):
Springs http://www.amazon.de/dp/B01DPLWZYO (9mm, default is ~7.5mm?) (amazon germany)
LM8UU Linear Ball Bearing http://www.amazon.de/dp/B009HW409O (amazon china shipping)
caliper http://www.amazon.de/dp/B00374O296 (amazon germany)
M6 X 30 Teflon Throat for MK8 Tube http://www.amazon.de/dp/B015FG9YP0 (amazon germany)
0.4mm Nozzle http://www.amazon.de/dp/B016B22N8M (amazon germany)
Complete Hot End Set ("All Metal Hotend") http://www.amazon.de/dp/B00V5W00RU (amazon germany)

Spare parts (default):
Teflon Tube Screw http://www.ebay.de/itm/262217384411 (intenational china)
Teflon Tube http://www.ebay.de/itm/261942436483 (intenational china)
Block Heater for Hot End http://www.ebay.de/itm/272141557109 (local germany/europe - looking for intenational)
lmk10luu vertical linear bearings http://www.amazon.de/dp/B019MLCKUK (amazon china shipping)
bearings http://www.amazon.de/dp/B011BHCWT2 (amazon china shipping)
Hammer Head Drop In Typ T-Nut M5 http://www.amazon.de/dp/B01DB8BIQC (amazon china shipping)

Parts that i needed to go on are from Amazon Germany: Prime saved my life :D
I am awaiting the LM8UU Linear Ball Bearing. My default Bearings seem to abrade (tolerance is getting to big) and start to vibe during print :(

If you need some translation help on 3d-druck-community.de german/english i maybe can assist you ;)
I hope I express myself somewhat understandable :D
Btw. what is your native language?/Where are you from?

Great to exchange experiences!

Best regards,
nosrev

By the way,

I saw that you updated the Block Heater, did you tried the e3V6 already?

No net yet, just ordered a couple of things from aliexpress, thank you for the tip ;)

[AliExpress]/item/Free-shipping-Aluminium-Heat-Block-for-E3D-V6-J-head-3D-Printer-RepRap-Makerbot-MK7-MK8/32315203521.html

[AliExpress]/item/Wholesale-20-teeth-Bore-8mm-GT2-Timing-Pulley-fit-width-6mm-of-2GT-Belt-3D-Printer/2038355968.html

[AliExpress]/item/Hot-sale-2meter-GT2-6mm-open-timing-belt-width-6mm-GT2-belt/32259050610.html

[AliExpress]/item/J-head-Bowden-Heatsink-For-1-75mm-Filament-remote-J-head-3d-printer-E3D-V5/32566158493.html

[AliExpress]/item/stainless-steel-throat-3D-printer-throat-hot-end-for-1-75mm-with-Teflon-tube/32436291948.html

Did you found our Stepper online? I only found this link here: https://gzslmotor.en.alibaba.com/product/60354414477-802134067/NEMA_17_STEPPER_MOTOR_1_68A_12V_24V_42_42_40mm_3D_printer_motor.html
But it looks like it's not for private use :(

P.S. Had to edit links, otherwise i could not have posted this :/

hEY sIR.

i'LL NEED A LITTLE help.

Printer just arrived, I build it but I can't run a simple Auto home, the only axis that apparently works is the z one. What should I do?

Hey,

what do you mean by "the axis that apparently works"? The z Stepper is moving? T8 lead screw is moving in the right direction? Stepper stops if the mechanical endstop is reached? (when running auto home?)

Do you hear any sound coming from the other steppers?

First check the right wiring in the instructions.
https://www.dropbox.com/s/n7nbuifeuyzrihh/CL-260.zip?dl=0

After that (if they don't make any noise) check weather the other steppers are not broken by wiring them to the wiring plug of the z stepper.
If the Steppers are not moving check weather they are moving when not assembled/check weather there is resistance when moving the axis (you should be able to move it by hand)

You can control all steppers (except the extruder - not moving) in Menue under "Prepare"->"Move axis"->"1mm" ->

Hope i could help so far.

Excuse my brevity, send from my Mobile ;)
Best regards.

z moving ok, end stop for z is working/

x moving and end stop working

y making noise, like having difficult to move

so bottom line the auto home only validates x a z, Y making noise and not moving right.

If I try to move from the LCD but only z and x

Had exactly the same problem with my X and Y axis at the beginning. Try to readjust the distance between the two plastic parts surrounding the linear bearings. Try to readjust the ball-bearings of the moving axes.
But most important thing that did the trick was to readjust the syncrous belts with the syncronizing wheels (use the two distance holders and try to set them as far as bossible two both sides).

could you send me a photo of your printer.? I provided my e-mail through private message.

X working fine now
Z ok

the Y axis apparently it is inverted. It is marking my home as 250 and when I try to move it it only goes when I try negative number!

The problem that a I saw two was that in one direction of the Y axis it goes smooth but when it tries to return it make the noise!

y axis is intentionally inverted (or NOT inverted) in CL-260.

reason for that is, the home location is left back,
but Cartesian coordinate origin is left front.

so left back home would not be 0,0,0 it would be 0,250,0

mechanical binding is big problem with this printer,

you need to adjust belt, rod, pulley, motor etc to make everything perfectly parallel to reduce binding,
which will make the stepper motor skip steps.

also, you want to adjust the stepper motor driver current to max, which will prevent skips,
but also it will make the stepper motor and stepper driver run hot,
which will require fans to cool.

Liked. Here in Canada I don't have the same shipment like Prime for the parts you mentioned, so I lot of things I will need to wait a lot to arrive or pay more to deliver it fast!