Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Z Over Movmnet, Z Calibration?

Please Login to Comment

I don't know what's on, its a new build. The Z movement is way over what it should be. I had the axis move 40mm but it moved 52.23mm. I am using the firm ware form the kit manufacture and checked #define DEFAULT_AXIS_STEPS_PER_UNIT to the Prusa calculator (https://www.prusaprinters.org/calculator/) the values are correct.
Any ideas.

If they were correct your printing would be correct. Are you changing your steps in the menu or in the firmware? If you are doing it in the firmware you probably need to do a fail safe restore in the menu to see the changes. If you are doing it from the menu? Try dividing the Esteps you are using now by 5 then sub track that value from your current Esteps. I bet that will get you closer to correct. You will need to fiddle with the value to get it exact. Then use the Save in the menu to make the changes stay. You will need to change the values in the firmware so you have them for a future flash.

So after messing around with it all yesterday night I realized the stepper driver was bad it was one that I did not replace. But still the prints are just coming out terribly right now the difference in the Z height is 1 mm over 40 mm move. So not bad but not the best. However the prints are just garbage still. I'm getting desperate to get this working so if you have any ideas please take a look at the attached pictures and let me know what's wrong. Please note I did not make changes to the firmware because the statue are correct as per the prusa calculator.

That is under extruding like crazy. Did you replace the drivers with ones of the same step?

Yes and recalibrated. I'm just getting so frustrated with this build I'm ready to take the printer apart and using it to bash out my own brains LOL

No no, it can be figured out. But I admit I have had a few projects I heavily though about doing that to. Looking back at that print i can also see that it skipped steps in the Y or X axis to. Have you checked your stepper current voltages?

Can you post a picture of your configuration file for Marlin and a photo of your Board? I will try to help you figure it out.

That was silly of me. I accidentally flagged my own comment. But anyway. I have used the vref the values from the Folger Tech forum. As I'm not sure what motor I have received from Folger Tech. The model number on the back of the stepper motor does not show up on search results on folder Tech's website or Google. So I have no way to calculate the correct vref.

I changed the board and print results got a lot better, as previously mentioned I've pretty much had to change all the electronics that these guys have sent.

But still having issues. The nozzle keeps hitting the print. And hard enough to slow down the y-axis on that side. Can't really get it to the second layer Take a look at the attached pictures looks like there's a bit of a gap between the two Extrusion lines. Could be some sort of Cura issue as the printer shows it's printing this first layer at 0.3 when I've asked for a 0.5 layer height.

What part of the configuration file do you need me to send pictures of?

Those pictures are very telling. It is skipping steps. And the under extrusion is probably related to the Z height being off.

The skipped steps could be the belts loose (you want them guitar string tight) or is is printing to fast. Email me your complete config file or zip your complete firmware and send that. w9amr at aol.com. I will look it over, Can you also take a pic of the complete printer.

I will try to help as much as I can.

Larry

Thanks so much I am emailing you now.

I have used Vref setting form the folgertech forms, as folgertech as not replied to my emails asking witch motors they have sent, and the model number on the motor does match any thing on there website or google, so cant use the vref formula for calculations. Ended changing the board and have had huge improvements. but something is still off. Prints are better but now the nozzle is hitting print and looks like steppes missing, gaps in the first layer pics attached, this print cant really higher then the first layer as it keeps hitting model hard

What part of the marlin conf do you need me to sent pics of? and i have attached pics of my bord.

I had the same problem with RAMPS1.4. I solved it! I soldered small capacitors (680pF) between GND and STEP on every steppers drivers. Capacitance may be from 470pF to 1nF or more.
The source of problem (all axis) is EMI from cables of motors, it produce additional steps, no steep loss. Now I can print on any speed.

On your last picture cable to motors goes close/over steppers and mainboard - it produce big interference. I twisted pairs of cables but it helped only on very slow prints (20m/s).

How are you doing on your printer?

Larry