MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now


Please Login to Comment

I was hoping that Marlin would leap to 2.1, but no. Anyway, the latest full release works well on the stock Predator, and you can even use the MarlinUI, rather than the ClassicUI. MarlinUI is a full color touch screen interface. Temperature control seems more stable, as it should, since they finally realized that the Trigorilla Pro uses 12 bit, rather than 10 bit ADC's (thanks to me). In my opinion, it's still not good enough for platinum RTD sensors, but I'm working on that.

Motion control (steppers) seems to have been tightened up a bit, although I have no proof of that, other than M48 reports more realistic and repeatably believable values.

If you do use MarlinUI in configuration.h, you will have to "de-comment" Mesh_Edit_GFX_Overlay in configuration.h to get it to compile. Under ClassicUI, it compiles fine, and seems to work well. Bug report submitted.

Hi, can anyone explain why with marlin the print head kind of acceles/deacceles in the middle of a movement, but it's like stuttering...

Hi, can anyone explain why with marlin the print head kind of acceles/deacceles in the middle of a movement, but it's like stuttering...

What version of software? Also, check your motor current. The stock Anycubic motors are 1.68 amps.

2.0.9 bugfix, voltage checked...
See the video to understand what I'm saying

Why were the files removed?

What files? You may be thinking of an earlier thread with the release, which is still there. If you want the latest release, go to the Marlin GitHub and download the most recent bugfix and the associated configuration files for the Anycubic Predator (under the "delta" examples).

Compile using Platformio under VSCode, and install the firmware.bin using the instructions in the file, using the STMicro Demonstrator GUI. Make sure you create a back-up of your existing firmware before you start!

So there was no files on this thread?
You're saying that I just need the latest bigfx and the the config files compile and there's no need to change anything correct?

There were never files for this thread. And I'm NOT saying you can just compile the latest bugfix. No version of Marlin for the Predator has ever been correct, since day one. Just as one example, the delta height has never been right, and still isn't.

Your best bet may be to get the latest bugfix and it's two configuration files for the Predator, and do a WinMerge compare with the configuration files available from the earlier thread on this forum.

Keeping up with Marlin can be a full time job!

Ok, thank you very much...
Is it better to use 2.0.9 or 2.0.7?

I'm currently running the latest bugfix release, with the Color_UI interface. It takes a bit to get used to, but I like it very much.

You made it to easy for me last time, my predator is almost the same as yours. I'm using the omg v2s extruder now.

I just had a issue start with the filament sensor, it's not the filament sensor from what I can tell. It was working fine then yesterday started acting like there's no filament randomly. Maybe I should add on the smart filament sensor, has anyone been successful yet?

Also it started going to a random spot for filament change, will not home then crashes into the part after restarting and is at an angle when trying to resume. I have not seen anyone else have the issue when resuming. It will do test just fine, it will calibrate just fine and until yesterday changed filament just fine. Maybe my firmware corrupted somehow?

I tried to compile and use latest bug fix but touch screen is not responding to inputs .. using Classic UI . I see the buttons but no action when I click them. With Marlin UI it hangs on bootscreen..
Any suggestion ?
I selected Anycubic TFT in Configuration.h as per Predator example config

The filament sensor is just a small micro-switch, with a lever that presses against the filament. The tip of the lever wears out eventually, and can cause issues like yours.

Open the filament sensor and VERY GENTLY bend the tip of the lever so that it touches the filament again. Let us know what happens.

do you have a compiled package like your last one that I could flash?

@dectoo, I'm sorry, but I don't. My predator is so heavily modified at this point that my firmware.bin would effectvely break your stock machine.

You don't have a stock one compiled laying around? Save me the trouble of downloading all the crap to compile it :)

@dectoo, what you are asking is for me to do a file compare on all of the files that I have changed in Marlin for my modded Predator (not just the config files, mind you), and pre-compile a bin file just for you. I'm a nice guy....but.

Bite the bullet, get a copy of VSCode and the PlatformIO extension, and go to town! It will take you about 30 minutes to figure it all out, you already have the flashing process working, and you get the added benefit of drilling deep into Marlin to understand its capabilities and shortfalls (and there are many).

If you have a working printer, I wouldn't spend the time or effort to try and keep up with the Marlin "updates". I generally do a new compile when there is a bugfix release just so I can report what has been broken. Its not pleasant, unless you are in to that sort of thing.

I bit the bullet and got it compiled. Are you having any issues with UBL? Mine will probe the bed 1 time and then tell me to stow the probe. I've tried from the LCD and grom G29 P1.

@dectoo, I've gone back to Marlin 2.0.9. has too many issues for me to deal with, including PID tuning and bed leveling. The broken PID tuning is probably partially my fault, since I filed a bug complaint that Marlin was not using the full capabilities of the analog to digital converters on the controller board. When that got "fixed", PID was broken.

I use an under-bed piezo nozzle contact sensor for delta calibration and UBL. It works fine under 2.0.9.

For real, is so much garbage. It keeps changing my Z height and I do not know why or how to stop it. Maybe I need to turn off some stupid random command. 2.0.9 is also broken all I get is that my files are to old to compile, these are the file that come with is so obviously major trash from this junk. Got bed leveling to check 4 spots but that's the best I can get it to do anything else breaks it. It was adding 15 to 25mm to my z height then going to 0.85mm for first layer? now it's adding on 10 to 20mm to z then going to 15mm for first layer... 15mm first layer is crashing into the bed but not as much as 0.85 but definitely not trying to actually move 14mm past the bed so it does not make sense.

ChuckAndy, I'm not comfortable supplying my config files for 2.0.9 because I GUARANTEE that if you use them, the resulting Marlin compile will trash your printer.

If you are having issues compiling 2.0.9, it's because you are using config files from an older or newer version of Marlin, which isn't allowed.

LMAO, just for the record, I guarantee if I used your files the only thing that would happen is the arm geometry would be off since I currently have all aluminum rods which makes it sing fancier then carbon fiber. Is your extruder 0.9 degrees like mine?

Have you ever used winmerge?

I am having an issue compiling? So out of the box the issue is my fault? Ok let me explain this very simply: download, unzip, compile, does not work..... so that would be out of the box issues. Now after I fix the files it's download, unzip, compile, edit, compile, does work.

Marlin download, unzip, compile, edit, compile, does work but software does it's own modifications adding Zmm, watch run line by line, edit, compile, does work but is a little bit wonky adding the z height then deleting it immediately.

I laughed when you said my filament sensor was possibly faulty, tho I had already confirmed it was not, I should not of had to as a faulty filament sensor does not cause a non homing issue, especially when the issues surface after running the software successfully many times.

I also had a good laugh when you said you paid $800 fore force gauge, mine was far cheaper and is Boeing certified for NASA projects. You also should use a orchestral tuner too. I use multiple so I can see that the belt is stretching evenly.

If I can debug bed leveling then I doubt your configuration files being used as a reference would have any impact.

All I have seen from you is stock stuff that's always been available which would do far more harm to my modified predator??? or Do you think that using configuration files which are supposedly supposed to be similar machines would cause more damage???

So did you do the upgrades to your predator or not?/? because now I'm suspicious since you basically just said that you did not do any of those upgrades as you have had no problem providing "stock" but not changed with a warning, because muh special files are so special that no other machine can be that special.

I think now I'm going to keep working on debugging and fixing Just got to figure out that extra z mm's but I already negated marlin adding it on, so I will have it running it probably after I eat this burrito, with a little bit of luck I will be successful before the last bite.

Can you upload your configuration files for 2.0.9, I ordered mag balls so the only difference between ours is I have yet to ground out the a4988 pins and I am using the OMG v2s extruder. My filament sensor was fine, I can not figure out why it's setting the z to 400 after filament change instead of going to home it stops hard. I noticed the z had changed in the settings to 400mm tho it's set in software and at the start shows the correct 417mm z. I'm going to start with a new marlin 2.0.9 so I would like something to compare too.