Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Extruder unfeeding all of the filament mid print.

Please Login to Comment

While printing the print just stops and unfeeds all of the filament, then tries to feed it back in before unpausing. tried reflashing the firmware but that did nothing, don't know if it's a slicer issue or a firmware issue.

That almost sounds like some Cura plugin is running amok, but those need to be enabled (you would see a small box near the preview button - see the pic). Did it ever work correctly, or is it a new problem?

used to work correctly, it's a cura issue, tried with another slicer and it seems to work fine, have no plugins so that is not the issue

Are you running this from an octopi or the SD? If running from Octopi, maybe try the same gcode with the SD and see if it has the same problem.

Printing from SD

Sorry to hear that, but good that you pinned it down to Cura - which version are you running, and which slicer did you use which worked? There must be something in the GCODE that is commanding the printer to do this and should be possible to find in there. Since you said it did all of the retraction and refueling automatically, it does not sound like an M600 (filament change), so it could be that there was a glitch in the value for the extruder "E" as the gcode progressed, really weird. You could search for "E-" in the gcode to see if there was a flipped value somewhere in the code (there will be negative values at the very beginning and very end, but not the middle normally).