Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Z Leveling issue, Newbe here.

Please Login to Comment

So I’ve finally had time to try my new Anycubic Kossel but when I try to do the 1st step Auto Leveling the print head moves down and over to towards the left front Beam it takes 2 to 3 readings and then comes down off the plate and against the left front beam, no mater what I do it does the same thing, it keeps wanting to wedge up against the left front beam, it’s almost like it thinks it’s going to center but it’s going to about 30 mm from the side, does two or three level checks and then is off the plate and against the beam, it seems like it thinks it’s in the middle of the plate but it’s not.
I’ve centered the printing head all the way up then turn it on to start leveling, the head goes down but as it goes down it moves to the left front and does the 1st bed touch about 30 mm from the edge and then it just works itself off the bed and wedges up against the beam, I turn it off and rest everything and it does the exact same thing, I have not made any changes to the program, I assembled it checked everything over and it just wants to go to the left front beam. I would think it should go straight down and start it’s 69 point reading in the middle not way over to the left front.

This sounds like the old firmware bug. I had a similar issue out of the box. It first autolevelled ok and I set the Z offset up correctly. I then attempted a test print from the SD card, where it proceeded to print a model about 3 inches above the bed, and towards the front left of the printer. I tried recalibrating and levelling again but the printer had developed a love for the front left tower and kept trying to ram the print head into the build plate near the tower. I contacted Anycubic and they sent me the link to the correct firmware on their website. A quick reflash and auto level and it's been fine since.

This is with the built in auto-leveling routine right? I don't run the stock firmware anymore partly due to it losing the settings (offset or height cant recall which), but this seems familiar (I don't recall what it was though). Does it auto home correctly? Also did you run (then save) the set z height first, which should drop to the middle of the plate for the measurement?

Also the way I recall auto leveling worked was by moving to one edge near the front bottom of the plate, and then stepping off across one row at the front doing maybe 3 or 4 points, then moving up a row, working from the near side to the far side, then up another row closer to the top, continuing this way till it got to the top row. It moved a zig zag like way from front to back in rows. But it should not have got stuck on one side of course.

Indeed, autoleveling starts at the front-middle of the bed, and works its way to the back. You can try to lower the head manually (move z-axes). If it goes to the left again it is likely a hardware failure. You can try swapping the left and the right steppenmotor, if the problem is the same, maybe it is the steppendriver (voltage?), if the problem mirrors to the right it is probably the motor.

(I assumed you first homed all the axis with the firmware. If not do that first.)

Apologize for not replying back I have health issues that kinda get in the way of doing things but anyway just out of curiosity I turned the Kossel on and went to do the 1st auto leveling again and same thing happened it did 3 points on the bed as it went to the front left and the fourth was off the plate and jammed against the belt, it does not home correctly, I think I need to update the firmware but when I tried to hook up my laptop to the Kossel it would not connect, I tried both blue cables I have and the laptop isn’t connecting or the printer isn’t connecting to the laptop, it’s a new HP laptop I just bought a couple months ago, I did download a Beachy Tank onto a usb and put that in my i3 mega and it printed off the Beachy just fine.
I would think I could just plug the laptop into the Kossel and it should connect, makes the sound like it want to connect but it doesn’t do anything, cant even start to clear eeprom to reload a file I recived from Augus.
Think I have a bad motherboard or something.

Check if it comes down correctly if you lower the z-axis with "move axis" on the printer menu. If you lowered the z-axis check if your x and y axis moving correctly and the z stays leveled.
If it does not home correctly check the stop-switches at the top. Cable correct? Does the motor stop?
The additional firmware for the bedleveling sensor can be incorrect. It is a known problem, you can download this piece of firmware from anycubic: http://m.anycubic3d.com/support/show/594034.html (nr 3)
If you can not connect to the printer, check in your windows device manager if your com-port is connected. If not, (re)install the driver. Still not working check youtube and search for "arduino connection problem"

If nothing works, try contact the helpdek from anycubic, it is fairly good.
Get well soon.