Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

i3 Mega S/Trigorilla with an E3D PT100?

Please Login to Comment

Hello everyone. I'm in the process of upgrading my stock Mega S for higher temp materials. I've printed CF PC up to 260/90 and get pretty decent results. However, I think there's a bit of better layer adhesion and major speed increases to be gained. I have a new Bondtech BMG to convert it to direct drive and a new blower. The hotend I have is an E3D V6 Ultimate Edition(https://bit.ly/3irvn3k). I also have the E3D PT100 Sensor and Amplifier Board (https://bit.ly/2PA5lhT). I've printed the necessary parts for this (https://bit.ly/3kzWxqD).

Now, I have the documentation/schematic for the Trigorilla board and after examining it, and researching, I've seen a bit of conflicting info on how to connect the PT100 amplifier board. I've attached the Trigorilla pinout and the PT100 amplifier pinout here. I simply wired the 40w heater cartridge in the same place as the stock hotend was (HEATER0 - D10), which I believe is correct. I know how the PT100 sensor connects to the amplifier board. Easy. The confusing part is, how do I connect the PT100 amplifier board to the Trigorilla board (there's 3 pins on the side that connects to the mainboard from the amplifier?)? I can see the 5v and gnd on the AUX pins, but the other two are D42 and D43 (I suspect digital but the PT100 requires analog if I'm not mistaken). What do I need to do? If someone has done this or clearly knows exactly what needs to be done or how, I'd be very appreciative, and would definitely PayPal/CashApp to show some appreciation if it works. Thank you in advance.