Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Mega-S extruder with TMC2208 noisy

extruder i3Mega noise TMC2208

Please Login to Comment

Hello good people of Thingverse,
I just upgraded my Mega to Mega-S and with this opportunity I upgraded drivers to TMC2208, changed fans to silent, changed couplers and so on. I also changed extruder stepper to original E3D with 0.9 degree/step (not the smallest pancake package but this bigger one used with titans https://e3d-online.com/motors-compact-but-powerful-motor ). This bumped up my extruder resolution from circa 100 to almost 800 steps/mm (makes sense as E3D motor has twice resolution of stock one and -S extruder is rated 300-400 steps/mm).
All works silent and great.. except said extruder. I cannot set retraction speed over 20 mm/s or I get extremely loud noise of grinding gears. It does not seem to be problem with filament gripping, rather gears inside and/or motor make this nose. Even with 20 mm/s it is the loudest part of the printer.

Now, I'm wondering, is this normal? Was this motor an overkill? Is this geared extruder so loud?
What would you suggest to do? Go back to original extruder? Original stepper? Original driver? Order Titan extruder (although it seems Mega-S extruder is clone of Titan).
I'm running marlin 1.1.9 ( https://www.thingiverse.com/thing:3249319 ) and ref. voltage for driver is already at 1.35V.

Thanks for any advice!

Anycubic i3 Mega / Mega-S Marlin 1.1.9 Custom Firmware - Extra Features & Quality Tweaks

Can't really comment on the hardware as I don't have a Titan/Mega-S extruder myself, but generally they can't be run on the typical i3 Mega extruder speeds of like 50mm/s and upwards. Also, acceleration can be key.

I recently had some people testing good values for the Mega-S extruder for my firmware.

  • Set retraction speed in slicer to 25mm/s.
  • Enter the following GCodes:
    M204 R1500 ; set default retract accel to 1500 mm/s²
    M201 E1500 ; limit max extruder accel to 1500 mm/s²
    M500 ; save values to EEPROM

Also, make sure to either lower or disable the extruder acceleration settings in your slicer. In Cura, they are to be found under the advanced options.

If it's still noisy, it might just be the high amount of steps from your new motor - so I'd recommend swapping it for the original then. Otherwise these settings are known to work well on TMC2208 (spreadCycle) + Titan style extruders.

Thanks, David this helped heaps with my mega s nite and day prints just updated to tmc2209's and set stealthchop on xyz and spreadcycle on e0 I kept skipping steps getting a grinding noise needed to up the vref to 1.1v and set the above retraction and e0 gets just warm

Thanks for response!
I didn't even know Cura has this setting. I was looking for it yesterday and could not find it. I set it with GCode but I failed to see difference. Maybe this is why. ;)
I think I've seen some discussion on your firmware comment section about those values and played with it. I even went as low as 750 for accel but as I wrote above I failed to notice much difference. I will look for cura override.
Also (before I even check how to do it) - spreadCycle mode of TMC2208 only helps with torque of the motor - right?

Thanks again.

spreadCycle mode of TMC2208 only helps with torque of the motor

To keep it simple, yes. Can't say if this is what causes the noise, but generally geared extruders might need more torque.

Before looking into switching to spreadCycle, I'd try swapping the driver for the original one first. The A4988 do deliver a decent amount of torque. If it still doesn't work, 800 steps might be just too much, but no clue really.

Well, I'll be damned.. I took extruder apart, oiled its bearings, put it back together, watched closely taking into account your comment and IT IS torque issue. When setting too high accel and feed rate motor just stalls. Seems 30 mm/s and 1500 mm/s^2 is its maximum. Just to be sure I'll use 25 mm.
Tommorow I will try rising vref on that driver to 1.5V and if it does not help I will switch back to A4988 and see how it likes that.
Thanks a lot!

Hi,

I am interested if you found a solution. I have similar setup and same problem. I took off the motor from extruder and behaves same so I also believe it is torque issue. Actually I am using extruder with a clone pancake motor from Triangle labs. Works pretty well, but has same resolution as stock motor. I tried playing with driver currents as well, but without positive results. I was thinking to try UART mode for the extruder driver, but need more info to make the config, like correct pin and the exact setup in the firmware.

Thanks,

For now I upped ref. voltage to 1.5V and switched back to original Mega extruder (resolution is above 100 steps/mm and I can get over 60 mm/s retraction speeds - so I'm happy for now). I switched back to old extruder because while I could get around 30 mm/s retraction without stalling sound was unbearable. I'm waiting for titan clone from triangle labs to play with it further. From what I read and researched I found that actually marlin 1.1.6+ has problem with extruder resolution greater than 800 steps/mm or so (there is bug on github for that).
When I get my hands on that titan clone I'm planning replacing driver back to A4988 and repeating my tests. If that fails, I will put back original motor which will get me to 400 steps/mm territory - this HAS to work.. right? ;)

Did you ever get back to this and find anything else out? Having this exact same problem with 2208 drivers, e3d compact but powerful motor, and my titan extruder on my i3 mega.

I bought Bondtech dual drive extruder - more or less same problem as with Titan. I went back to A4988 but I hated sound it generated, went back to TMC2208 again and upped voltage to 1.75. I could get to 35 mm/s. With such high voltage my TMC2208 finally died. I went back to A4988 again and have to live with that. That's the current state that I don't think I will change unless I learn some new way.

That should work. I have the Titan clone and pancake motor from TriangleLabs and is working OK with TMC2208 and of course 400 steps. I was using 60mm/s retraction myself as well before, but now I have only 30mm/s with 3mm and works veri nice. Not stringing with PLA I use. I have bowden setup with changed PTFE tube and E3D hotend clone, full metal. I do not remember exatcly but original motor with Titan clone also had some issues for higher speed retractions (above 50mm/s I guess) so I stayed with this clone motor...Please share your results with original driver tests...