Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Layer fan always on

Please Login to Comment

Hello guys :D
I've got a problem with one of my fans. The layer one is always on, as soon as i turn the printer on the fan starts to spin at maximum speed and there's no way to stop it, nor via LCD nor via USB. I think that some electrical part just died somewhere. Do you have any idea on what could cause that? I thought that maybe i can work on the main board, switch the "port" of the layer fan with, i dunno, the PSU fan? In that case the PSU fan will be always on, but i don't know if this could cause any problem. Also, by doing that, i have to change something in the firmware but i really don't know how to do that. I tried googling it and I didn't find anything really useful. Any idea on how to fix this? Maybe buying a new trigorilla?
Oh, and i also wrote an e-mail to anycubic, but they didn't give me an answer.

FAN0 transistor is probably damaged. Was the printer turned on while you replaced your fan? Having no load on that port with the mainboard powered can kill it.

See the image attached. Replace with IRLML2502, AO3400, FDN335N or similar if you are comfortable with SMD soldering.

Hello and thank you for this advice! I recently faced the same problem (plugged new 5015 fan while printer was on), it was blowing 100% all the time after powering printer on. Even with my little soldering experience I managed to replace transistor with IRLML2502, and now everything works again. There was a little burnt dot on stock transistor.

any idea why? this seems very.. strange... as someone who does hobby electronics.
it's a very weird and stupid design tbh. how hard is controlling a fan? isn't it just a pwm to a transistor?!

No idea, I'm a software guy, I do hobby electronics myself but circuit design is way over my head. This is definitely a known issue for Trigorilla boards, might just be missing some particular protection circuitry, but I really don't have a clue.

But we often underestimate what it takes to make a safe circuit design. I recently looked into safe PWM controlled hotbed circuits. Turns out reverse voltage is actually a big issue and most printer boards (e.g. RAMPS, Melzi, RUMBA) lack the freewheeling diode to mitigate that. It still works well for most because the MOSFETs are reasonably sized.

Anyways, the puny little J3Y transistor on FAN0 just loves to fry in those occasions, not much you can do. You won't have that issue anymore, replacing it with a proper one from Infineon, etc.

So overall what is the best course of action to get the layer fan on fan0 back up and running? And also where do you suggest i could start looking to get the basics on learning on circuits and wiring and connectors.

I can't recall if the printer was on or off, maybe off, but i'm not sure. I'm not confortable at all with any tipe of soldering, i will give it a shot anyway. Before doing that i will surely buy another trigorilla, though. If i will fuck things up with my lack of skill in soldering i could at least change the whole board

Did you work on the printhead recently?

I changed the stock fan with a 5015 yesterday, but yesterday everything works normally. This morning I had this problem

Sounds to me that you switched the plugs of hotend and part coolig fan...

But I removed only the pin of the fan, not both :(

Maybe you could show pics so we all know what connection is causing issues? Also can you confirm that you can't stop the fan with the touch screen (Setup>Speed>Fan speed 0>OK)