Loading

MakerBot Print is our newest print-prepration software, which supports native CAD files and STL assemblies,
allows you to interact with all your printers via the Cloud, and many other exciting new features.

Download Now

Nozzle suddenly stops heating up

Please Login to Comment

Hi all,

I saw someone talking about a similar problem but I thought I'd share mine in a different topic. Yesterday, my Anet was printing as usual (PLA - 190C/60C) and suddenly the nozzle stopped heating up and the extruder motor failed too (both at the same time). I can't tell if the stepper driver for the extruder motor is burnt or it just won't budge because of the <170C nozzle limitation - I heard that Marlin won't let you use the extruder motor if the nozzle is colder than 170C. I will test it as soon as I get home.

I should mention that yesterday morning I added one more part cooling fan to the printer and it did manage to carry out a couple of prints flawlessly. I hooked them up in parallel and they are running at 90% capacity since the nozzle can't really keep up the temp (yes, I did the auto PID). Also, the power supply seemed to be struggling too - it was hot enough that I could barely touch it.

I do have a spare ramps+leonardo which I was going to use for the new printer I am building so I think I will switch to those if there is no other alternative.

Specs: 2 mosfets, stock board, stock power supply, stock bed, e3D V6, 2 part cooling fans, Marlin 1.1.9

Final Update: After many hours of debugging and frustration, I finally found the culprit - the lead from the power supply to the external mosfets.

So as a sum-up of the whole story: as my Anet was printing as usual (stock PSU, PLA temps, external fets), the nozzle and bed abruptly stopped receiving current. I later figured the external mosfets must've been at fault, since neither was outputting any current to the bed and nozzle and I was able to confirm 12V from the power supply to the fets (I checked the input terminals of the fets, not the output terminals of the PSU). However, it was a rather big coincidence that both of them failed at the exact same time. So, after getting me some new external mosfets, those weren't working either. The only thing left to do was trying a new wire for the power supply, even though, and I know I'm saying this for the 100th time, SAID WIRE WAS OUTPUTTING 12V as measured with a voltmeter.

For the new wire, I just used a regular AC lead. I also added a picture with the wire, to which I also later soldered some spade connectors. Note: before changing it, the LEDs on the mosfet lit up exactly the same, blue and red, so basically confirming input and output to the fets.

So, yeah, it finally works now. Thanks to everyone who responded to this topic and especially to Ambeos who suggested changing that main wire. :)

In your picture is a 0.75 - 1.0 mm cross section line grant, supply line Mosfet. Have in my construction 2x2.5 cross section on the heatbed and 1x2.5 on the Nozzel. 2.5er cross section is suitable for about 15A, equivalent to 12V about 180 watts.

New update: brand new external mosfets arrived but they still output 0V. This is getting really annoying.

I checked all the cables and connections with a multimeter: mosfet 12V input is ok, mosfet control input is ok, but the output to the heated bed is still at 0V and (naturally) the bed is not heating up. I also tried hooking up the heated bed directly to the motherboard and it heats up as it should.

Does anyone have any more suggestions on this issue? :(

Most of the mosfets have 2 LEDs on them one means its getting power and the other turns on when its getting signal from the board to heat the bed/nozzle, are these coming on? if not it may be the mosfet chip on the actuall main board in which case you will have to replace the mainboard.

Yip, both of the LEDs light up. It's really frustrating because I can't figure out where the issue is: the cables are all fine, the mainboard and mosfet connectors are ok.

Is it possible that the mosfet on the mainboard actually died and that led to the external mosfets not working? Mind you, the bed and nozzle work perfectly fine when plugged in directly to the mainboard. Also, this whole issue started during a print - the mosfets suddenly stopped working (as I eventually figured out).

well. you have checked all the connections, replaced the fets, confirmed that both the nozzle and bed work when attached directly to the mainboard, the LEDs turn on when signal is given on the mosfets, and checked all the voltage's so at this point im perplexed at why the bed and nozzle arent heating up.

Anyone else have any input?

That's exactly what's going on. As far as I can tell, maybe something happened to the main wire from the power supply to the fets - loose connection maybe? In that it confirms 12V (as previously checked with a multimeter) but it can't carry enough energy for the external mosfets.

That's about the only thing I haven't checked thus far. I still believe that I may be missing something really simple here. I mean, it's rather suspicious that both of the old external mosfets failed at the exact same time and the new ones don't seem to work either.

Its unlikely that the wire would fail like that but it is known the the clad aluminum wires suck and you may have got some unknowingly. you could try replacing the leads coming from the PSU to the Mosfets and see if that makes a difference. Also confirm that it is stable by trying to heat the bed or nozzle while having the multimeter on the mosfets inputs to see if they drop in voltage.

what version of the anet board are you running?, and i was refering to the LEDs on the external mosfets in the previous post, is the output led on the external mosfet coming on when you tell the printer to heat the bed?

I can't check the version right now as I'm not home, but I got the printer in october 2018, so it may be the latest one. And yes, both LEDs on the external mosfets come on when it's supposed to be heating the bed (the output voltage led as well as the input led from the power supply). It can't be a power supply issue either (not that it would have been really likely) since I just swapped it with a 30A power supply.

Just for reference, I added a picture of one of the old fets (right) and one of the new ones (left).

An N-channel mosfet goes through in case of wrong polarity, so pay attention to the correct polarity when feeding. The heatbed does not care how it gets around. Please check the polarity

I tried swapping the polarity too (on the output of the mosfets), but could this really be the issue? The external mosfets stopped outputting current midprint.

Polung not different than stated !!! Note positive pole, source-gate has less voltage than drain (mostly negative pole)

So is the nozzle heating up on the external mosfets ok just not the bed? If it is swap the bed over to the hotend mosfet(Unhook the hotend wires of course) and switch the control wires (Basically swap the mosfets on what they control bed or nozzle) ,then test the bed if it heats up you may have gotten a bad external mosfet from the factory. other than that im not sure what else could be the issue here if you have already checked everything else

Neither the bed nor the hot end heat up when hooked to the fets but they work fine directly on the motherboard. :(
Also, the motherboard version is V1-5 I believe.

As others mentioned, marlin is the reason the extruder won't move below 170C. So you should check your hotend stuff... power to heat cartridge & thermistor ohms. As usual, when troubleshooting these things you have to verify the whole circuit loop (from mobo PCB pin, to the device, and back to the mobo PCB pin).

I would bet that something you did when installing the 2nd part fan messed up wiring/connection to either the heater or thermistor.

UPDATE: After testing some more stuff out with a multimeter, the ONLY conclusion that I could come to is that BOTH of the connectors to the mosfets are fried - by this I mean the outputs from the mosfets to the nozzle/bed.

I know this sounds really weird. I tested everything else: power to mosfets, mosfets to board and after connecting the heating element straight to the board it started heating up sooo it's clearly not a nozzle issue.

Is this a common issue? Mosfets getting fried?

When you say you 'connected the heating element straight to the board it started heating...', where on the board did you connect? Straight to the 12V bus, or to the mosfet output before the connector? If it is the latter, a new connector would fix it.

Otherwise, yes unfortunately the low bin mosfets used on a8 boards can fail. The weird thing is, these n channel fets typically fail in the conducting state... so should be that the hotend gets too hot. If you happened to get lucky and had one fail open, good for you to not have a fire hazard as a result.

Regardless, the fix for a blown mosfet is either a) rework a new smd mosfet on the mobo, or b) wire up an external mosfet. Typically most hobbyists won't have the tools/skills to do a). To do fix b), you will have to solder a jumper wire to the gate of the on board fet to the gate of your external fet (not too hard... just gotta solder to the old mosfet pin which is relatively easy for most). Once done, you can optionally cut the pins off the old fet for safety.

On a side note, if it was ramps you could skip soldering a gate jumper wire and instead just configure marlin to use another free pin to control the external fet. It has been a while since I used my a8 board, but iirc there are some extra pins available where this could be done (ISP header iirc has some free pins).

And by mosfets, I was referring to the external mosfets.

What I meant was I wired the heating cartridge straight to the nozzle output on the board (exactly where it would normally go on a stock board, as I had it wired to an external mosfet).

Gotcha... so an external fet failed on you. You should be ok using the built in mosfet; just be sure the connectors are good and solid (direct solder if there is any question). The onboard fet is generally considered adequate for use... it is the bed fet that usually has issues especially if pwm bed heating is used (actually usually the bed fet connector on the mobo). Since the hotend is relatively low power (40W vs 200W) the onboard fet should be ok.

That said, I kinda wonder what happened to that external hotend fet. The typical external fet is way overkill for 40W... those things are commonly have fets capable of nearly 100A! So if I were to wager... I'd say you just had bad luck and got a defective fet on your external board. You should of course beware that fets are very sensitive to esd discharge... that said discharge failure is usually rare on an installed device (usually you zap em with your fingers while installing them).

I still can't be 100% sure. It's really weird: both of the external mosfets failed as far as I can tell (overvoltage perhaps?!). The leds on the fets light up whenever they are (or should be) in use, meaning they receive both the signal from the board and the power from the power supply (I also checked with a multimeter as previously mentioned). I took them off and took a close look and neither seems to have a burnt connector and I also didn't smell anything burning when the hotend failed during printing.

Anyway, I ordered 2 more just to be safe. The new ones seem to have gold plated connectors, the others didn't. I'm also getting a new power supply which I probably should have done from the start lol.

Edit: I'd say it would have been pretty unlikely for me to have zapped the fets with my fingers. I was pretty far away from the board when it happened.

to much inconsistent power can blow even the external mosfet, with your psu heating up that much im sure it was not producing clean power, just a thought

Yeah, you're probably right. I guess a better psu would have been a better upgrade in the beginning.

Your problem could be something as simple as a bad thermistor.

I still use the stock power supply (for 2 years) but anything I have added lighting etc. I power with a separate power supply. My stock supply only felt warm if yours is hot something is over loading the power supply, or there is a problem with the supply itself. If I ever replace my power supply I will buy a larger one just to have a little extra power.

The Anet a8 Power Supply is enough power if you are only powering the stock printer. About 6 months ago I add a fan to my supply just for the fun of it. I uses a thermistor to read the temp, used a Nano to control the fan speed and a 1602 LCD for a readout of the temp and fan speed.

I posted an update above, the thermistors are ok, I checked them. The problem lies somewhere around the mosfets' outputs.

in marlin, you can set the thermistor to 999 and thus test the extruder motor. The thermistor is faked 100 degrees. Just use #define TEMP_SENSOR_0 999.

Thanks, I looked into it and I'll just use M302 as soon as I get the chance.

Marlin does limit at 170 anything under that is refered to as Cold Extrusion Protection, as for what happened to your hotend test the power coming in to see what you are getting. If you dont get power it may be the board blew the mosfet on it. Also if your power supply is heating up that hot you need to get a bigger one i run 30amp on all my printers due to extra fans and lighting.